题目链接:http://nyoj.top/problem/715
- 内存限制:64MB 时间限制:1000ms
题目描述:
For a string of n bits x1, x2, x3, …, xn, the adjacent bit count of the string is given by fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*xn
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:
Fun(011101101) = 3
Fun(111101101) = 4
Fun(010101010) = 0
Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy Fun(x) = p.
For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011
输入描述:
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case is a single line that contains a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100
输出描述:
For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.
样例输入:
2
5 2
20 8
样例输出:
6
63426
解题思路
定义dp[i][j][k]:长度为i结果为j结尾为k(k=0,1)的方案数.
那么状态转移方程为,其中dp[1][0][0]=dp[1][0][1]=1.
#include <bits/stdc++.h>
using namespace std;
int main() {
int t, n, p, dp[105][105][2];
scanf("%d", &t);
while (t--) {
scanf("%d%d", &n, &p);
dp[1][0][1] = dp[1][0][0] = 1;
for (int i = 2; i <= n; i++) {
for (int j = 0; j < i; j++) {
dp[i][j][0] = dp[i - 1][j][1] + dp[i - 1][j][0];
dp[i][j][1] = dp[i - 1][j][0];
if (j)
dp[i][j][1] += dp[i - 1][j - 1][1];
}
}
printf("%d\n", dp[n][p][0] + dp[n][p][1]);
}
return 0;
}