1487: Adjacent Bit Counts


Time Limit: 1 Sec   Memory Limit: 128 MB

Submit: 50  

Solved: 20


Submit

Status

Web Board


Description


For a string of n bits x1, x2, x3, …, xn,  the adjacent bit count of the string  is given by     fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:  
     Fun(011101101) = 3 
     Fun(111101101) = 4 
     Fun (010101010) = 0 
Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy  Fun(x) = p. 

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2: 
11100, 01110, 00111, 10111, 11101, 11011


Input


On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case is a single line that contains  a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100


Output


For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.


Sample Input


2


5 2


20 8


Sample Output


6


63426


//题意:


给你一个01串,规定01串的值为x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n,


现在给你两个数n,p,n表示01串的长度,p为01串的目标值。现在问你有几种组合方法使得长度为n的01串计算的值等于p。


例如 5  2


有6种组合方法:11100, 01110, 00111, 10111, 11101, 11011


//思路:一个标准的01串DP。


dp[n][p][0]+dp[n][p]+[1]即为长度为n,目标值为p的01串的组合方法数。


其中n表示串长,p表示目标值,0表示最后一位是0,1表示最后一位是1.


所以状态转移方程为:dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];


                 dp[i][j][1]=dp[i-1][j][0]+dp[i-1][j-1][1];


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[110][110][2];
int main()
{
	int t,i,j,k;
	int l,n;
	dp[1][0][0]=1;
	dp[1][0][1]=1;
	for(i=2;i<=100;i++)
	{
		dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];
		dp[i][0][1]=dp[i-1][0][0];
		for(j=1;j<i;j++)
		{
			dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];
			dp[i][j][1]=dp[i-1][j][0]+dp[i-1][j-1][1];
		}
	}
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&l,&n);
		printf("%d\n",dp[l][n][0]+dp[l][n][1]);
	}
	return 0;
}




Source


河南省第六届大学生程序设计竞赛