Description
Input
Output
Sample Input
7 4
6
4
2
1
Sample Output
3
5
6
4
2
1
7
Data Constraint
思路
这其实类似于归并
要求字典序需最小,肯定把小的往前塞。
建两个队列,一个是题目的输入,一个是剩下的书从小到大排序。
做一次归并即可
代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e5+77;
int a[maxn],n,m,l,r;
bool b[maxn];
int main()
{
freopen("patrol.in","r",stdin); freopen("patrol.out","w",stdout);
scanf("%d%d",&n,&m);
for(int i=1; i<=m; i++) scanf("%d",&a[i]),b[a[i]]=1;
int l=1,r=1;
while(l<=n||r<=m)
{
while(l<=n&&b[l]) l++;
if(l>n)
{
for(int i=r; i<=m; i++) printf("%d\n",a[i]);
break;
}
if(r>m)
{
for(int i=l; i<=n; i++) if(!b[i]) printf("%d\n",i);
break;
}
if(a[r]<l) printf("%d\n",a[r]),r++;else printf("%d\n",l),l++;
}
}