Given a non-negative integer 【PAT (Advanced Level) Practice】1005 Spell It Right (20 分)_ios, your task is to compute the sum of all the digits of 【PAT (Advanced Level) Practice】1005 Spell It Right (20 分)_ios, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an 【PAT (Advanced Level) Practice】1005 Spell It Right (20 分)_字符串处理_03.

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five


#include<iostream>

using namespace std;

int main(){

string n;
cin >> n;

int s = 0;
for(auto c: n) s += c - '0';

string str = to_string(s);

char word[10][10] = {
"zero", "one", "two", "three", "four",
"five", "six", "seven", "eight", "nine"
};

cout << word[str[0] - '0'];

for(int i = 1; i < str.size(); i++) cout << ' ' << word[str[i] - '0'];

return 0;
}