Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given Lbeing 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤) which is the total number of nodes, and a positive K (≤) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
 

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
 

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

给出的数据未必都是链表中结点,所以先梳理一遍确认链表的结点个数,然后每k个一反转,注意首尾相接。
代码:
#include <stdio.h>
struct node {
    int data,next;
}s[100000],*t,*p,*q,*r,*head,*tail = NULL;
int main() {
    int n,k,address,a,b,c;
    scanf("%d%d%d",&address,&n,&k);
    if(k > n) k = n;
    for(int i = 0;i < n;i ++) {
        scanf("%d %d %d",&a,&b,&c);
        s[a].data = b;
        s[a].next = c;
    }
    int nn = 0;
    for(int i = address;i != -1;i = s[i].next) nn ++;
    q = &s[address];
    while(k <= nn) {
        t = p = q;
        q = &s[q -> next];
        c = 1;
        while(c < k) {
            r = q;
            if(q -> next != -1) q = &s[q -> next];
            r -> next = t - s;
            t = r;
            c ++;
        }
        if(tail == NULL) head = t,tail = p;
        else tail -> next = t - s,tail = p;
        nn -= k;
    }
    if(nn % k == 0) tail -> next = -1;
    else tail -> next = q - s;
    address = head - s;
    while(address != -1) {
        if(s[address].next == -1) printf("%05d %d %d\n",address,s[address].data,s[address].next);
        else printf("%05d %d %05d\n",address,s[address].data,s[address].next);
        address = s[address].next;
    }
    return 0;
}