Web Navigation
Time Limit: 1000MS |
| Memory Limit: 10000K |
Total Submissions: 23963 |
| Accepted: 10692 |
Description
Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/
Input
Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.
Output
For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.
Sample Input
VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT
Sample Output
http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored
//虽然给出了步骤,仍费了好大劲,此题很经典
#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main()
{
int i,j,k;
stack <string > b;
stack <string > f;
string s;
string cur = "http://www.acm.org/";
while(cin>>s)//cin以空格结束
{
if(s=="QUIT")
break;
if(s[0]=='V')
{
b.push(cur);
cin>>cur;
cout<<cur<<endl;
while(!f.empty())
f.pop();
}
else if(s[0]=='B')
{
if(!b.empty())
{
//在visit语句中最后一个还没入任何站
f.push(cur);
//这句话和下面那句一定不能搞反顺序
//Pop the page from the top of the backward stack,
//making it the new current page
cur = b.top();
b.pop();
cout<<cur<<endl;//始终输出当前页
}
else
cout<<"Ignored"<<endl;
}
else
{
if(!f.empty())
{
b.push(cur);
cur = f.top();
f.pop();
cout<<cur<<endl;//始终输出当前页
}
else
cout<<"Ignored"<<endl;
}
}
return 0;
}
作者:火星十一郎
本文版权归作者火星十一郎所有,欢迎转载和商用,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.