题目:

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^).

But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH


For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

解题思路:

先定义三个字符串数组,分别为入站的、停站的和出站的。若对应的入站的顺序与出站的顺序一样就输出
in--out;说明火车并没有在站台停留。若是入站的顺序与停站的顺序一样,输出in,说明火车停留在站台
,先进去的只能后出去;若出站的顺序与停站是顺序一样就输出out,说明停在站台的火车要驶出去;

程序代码:

#include<stdio.h>
#include<string.h>
char stack[10000],target[10000],eque[10000];
int main()
{
int n,i,j,t,a,b,top,k;
while(~scanf("%d",&n))
{
scanf("%s%s",eque,target);
a=b=0;top=0;t=1;
while(b<n)
{
if(eque[a]==target[b])
{
a++; b++;
}
else if(top && stack[top]==target[b])
{
top--; b++;
}
else if(a<n)
{
stack[++top]=eque[a++];
}
else
{
t=0; break;
}
}
if(t==1)
{
printf("Yes.\n");
a=b=0;top=0;
while(b<n)
{
if(eque[a]==target[b])
{
a++; b++;
printf("in\nout\n");
}
else if(top && stack[top]==target[b])
{
top--; b++;
printf("out\n");
}
else if(a<n)
{
stack[++top]=eque[a];
a++;
printf("in\n");
}
}
}
else
printf("No.\n");

printf("FINISH\n");
}
return 0;
}