Problem Description
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
Sample Input
Sample Output
Yes. in in in out out out FINISH No. FINISH
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
//栈的应用
#include <iostream>
#include <stack>
#include <cstdio>
#include <cstring>
using namespace std;
stack<int> S;
int main()
{
int n,i,j,k;
bool flag[10000];
string in,out;
while(~scanf("%d%*c",&n))
{
cin >> in >> out;
i = j = k = 0;
while(j<n+1 && i<n)
{
if(!S.empty() && S.top() == out[i])
{
i++;
flag[k] = true;
k++;
S.pop();
}
else
{
S.push(in[j]);
flag[k] = false;
j++;
k++;
}
}
if(k!=2*n)
{
cout << "No." << endl;
}
else
{
cout << "Yes." << endl;
for(i = 0; i<k; i++)
{
if(flag[i])
cout << "out" << endl;
else
cout << "in" << endl;
}
}
cout << "FINISH" << endl;
}
return 0;
}