Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

x to y? The length of the first and the last step must be 1.

Input and Output 


Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers:  0xy < 231

. For each test case, print a line giving the minimum number of steps to get from  x

 to  y

.

Sample Input 



3 45 48 45 49 45 50



Sample Output 



3 3 4



存在一定的规律。

相邻的两步必须是大于1或者相等或者小于1的而且第一步和最后一步都必须是一。求在这样的条件下需要走多少步。

       1 1

      1 2 1

     1 2 2 1

    1 2 3 2 1

   1 2 3 3 2 1

  1 2 3 4 3 2 1

 1 2 3 4 4 3 2 1 





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int a[110000001];

int main()
{
    int i;
    int j = 4;
    int k = 3;
    int ii = 4;
    a[0] = 2;
    a[1] = 3;
    a[2] = 3;
    a[3] = 4;
    a[4] = 4;
    for(i=5;i<=100000100;)
    {
        ii = ii + k;
        j++;
        while(i<=ii)
        {
            a[i] = j;
            i++;
        }
        ii = ii + k;
        j++;
        while(i<=ii)
        {
            a[i] = j;
            i++;
        }
        k++;
    }
    int T;
    scanf("%d",&T);
    while(T--)
    {
        long long int n,m;
        scanf("%lld%lld",&n,&m);
        long long int sum;
        sum = m - n - 2;
        printf("%d\n",a[sum]);
    }
    return 0;
}







Miguel Revilla 2002-06-15



  Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 

0xy < 231. For each test case, print a line giving the minimum number of steps to get from 

x to 

y.


Sample Input 



3 45 48 45 49 45 50



Sample Output 



3 3 4





Miguel Revilla 2002-06-15