Searching for Nessy 

The Loch Ness Monsteris a mysterious and unidentified animal said to inhabit Loch Ness,  
a large deep freshwater loch near the city of Inverness in northern Scotland. Nessie is usually categorized as a type of lake monster.

http://en.wikipedia.org/wiki/Loch_Ness_Monster


In July 2003, the BBC reported an extensive investigation of Loch Ness by a BBC team, using 600 separate sonar beams, found no trace of any ¨sea monster¨ (i.e., any large animal, known or unknown) in the loch. The BBC team concluded that Nessie does not exist. Now we want to repeat the experiment.


Given a grid of n rows and m columns representing the loch, 6nm10000, find the minimum number s

  • one sonar occupies one position in the grid; the sonar beam controls its own cell and the contiguous cells;
  • the border cells do not need to be controlled, because Nessy cannot hide there (she is too big).

For example,


X

Input 

t, indicating the number of test cases. For each test case, there is a line with two numbers separated by blanks, 6nm10000, that is, the size of the grid (n rows and m

Output 

For each test case, the output should consist of one line showing the minimum number of sonars that verifies the conditions above.

Sample Input 


36 67 7 9 13


Sample Output 


4412




#include<iostream>
#include<algorithm>

using namespace std;

int main()
{
    int n,m;
    int T;
    cin >> T;
    while(T--)
    {
        cin >> n >> m;
        n = n/3;
        m = m/3;
        cout << n*m << endl;
    }
    return 0;
}