Steps


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 7872

 

Accepted: 3612


Description


One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step. 
What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.


Input


Input consists of a line containing n, the number of test cases.


Output


For each test case, a line follows with two integers: 0 <= x <= y < 2^31. For each test case, print a line giving the minimum number of steps to get from x to y.


Sample Input


3 45 48 45 49 45 50


Sample Output


3 3 4


Source


​Waterloo local 2000.01.29​


你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include<iostream>
using namespace std;
int main()
{
long a,b,d;
int n,c,step;
cin>>n;
while(n--)
{
cin>>a>>b;
d=b-a,c=1,step=0;
while(1)
{
if(d<2*c)break;
else
{
d=d-2*c;
step+=2;
c++;
}
}
if(d>c)step+=2;
else if(d<=0)step+=0;
else step+=1;
cout<<step<<endl;
}
return 0;
}