Search III

Your task is to write a program of a simple dictionary which implements the following instructions:

insert str: insert a string str in to the dictionary

find str: if the distionary contains str, then print ‘yes’, otherwise print ‘no’

Input

In the first line n, the number of instructions is given. In the following n lines, n instructions are given in the above mentioned format.

Output

Print yes or no for each find instruction in a line.

Constraints

A string consists of ‘A’, ‘C’, ‘G’, or ‘T’

1 ≤ length of a string ≤ 12

n ≤ 1000000

Sample Input 1

5

insert A

insert T

insert C

find G

find A

Sample Output 1

no

yes

Sample Input 2

13

insert AAA

insert AAC

insert AGA

insert AGG

insert TTT

find AAA

find CCC

find CCC

insert CCC

find CCC

insert T

find TTT

find T

Sample Output 2

yes

no

no

yes

yes

yes

code

/*
^....0
^ .1 ^1^
.. 01
1.^ 1.0
^ 1 ^ ^0.1
1 ^ ^..^
0. ^ 0^
.0 1 .^
.1 ^0 .........001^
.1 1. .111100....01^
00 ^ 11^ ^1. .1^
1.^ ^0 0^
.^ ^0..1
.1 1..^
1 .0 ^ ^
00. ^^0.^
^ 0 ^^110.^
0 0 ^ ^^^10.01
^^ 10 1 1 ^^^1110.1
01 10 1.1 ^^^1111110
010 01 ^^ ^^^1111^1.^ ^^^
10 10^ 0^ 1 ^^111^^^0.1^ 1....^
11 0 ^^11^^^ 0.. ....1^ ^ ^
1. 0^ ^11^^^ ^ 1 111^ ^ 0.
10 00 11 ^^^^^ 1 0 1.
0^ ^0 ^0 ^^^^ 0 0.
0^ 1.0 .^ ^^^^ 1 1 .0
^.^ ^^ 0^ ^1 ^^^^ 0. ^.1
1 ^ 11 1. ^^^ ^ ^ ..^
^..^ ^1 ^.^ ^^^ .0 ^.0
0..^ ^0 01 ^^^ .. 0..^
1 .. .1 ^.^ ^^^ 1 ^ ^0001
^ 1. 00 0. ^^^ ^.0 ^.1
. 0^. ^.^ ^.^ ^^^ ..0.0
1 .^^. .^ 1001 ^^ ^^^ . 1^
. ^ ^. 11 0. 1 ^ ^^ 0.
0 ^. 0 ^0 1 ^^^ 0.
0.^ 1. 0^ 0 .1 ^^^ ..
.1 1. 00 . .1 ^^^ ..
1 1. ^. 0 .^ ^^ ..
0. 1. .^ . 0 .
.1 1. 01 . . ^ 0
^.^ 00 ^0 1. ^ 1 1
.0 00 . ^^^^^^ .
.^ 00 01 ..
1. 00 10 1 ^
^.1 00 ^. ^^^ .1
.. 00 .1 1..01 ..
1.1 00 1. ..^ 10
^ 1^ 00 ^.1 0 1 1
.1 00 00 ^ 1 ^
. 00 ^.^ 10^ ^^
1.1 00 00 10^
..^ 1. ^. 1.
0 1 ^. 00 00 .^
^ ^. ^ 1 00 ^0000^ ^ 01
1 0 ^. 00.0^ ^00000 1.00.1 11
. 1 0 1^^0.01 ^^^ 01
.^ ^ 1 1^^ ^.^
1 1 0.
.. 1 ^
1 1
^ ^ .0
1 ^ 1
.. 1.1 ^0.0
^ 0 1..01^^100000..0^
1 1 ^ 1 ^^1111^ ^^
0 ^ ^ 1 1000^
.1 ^.^ . 00
.. 1.1 0. 0
1. . 1. .^
1. 1 1. ^0
^ . ^.1 00 01
^.0 001. .^
*/
// Virtual_Judge —— Dictionary Aizu - ALDS1_4_C.cpp created by VB_KoKing on 2019-05-02:11.
/* Procedural objectives:

Variables required by the program:

Procedural thinking:

Functions required by the program:

*/
/* My dear Max said:
"I like you,
So the first bunch of sunshine I saw in the morning is you,
The first gentle breeze that passed through my ear is you,
The first star I see is also you.
The world I see is all your shadow."

FIGHTING FOR OUR FUTURE!!!
*/
#include <iostream>
#include <cstring>
#include <cstdio>

#define M 1046527
#define NIL -1
#define L 14

using namespace std;

char H[M][L];

//将字符转换为数值
int get_char(char ch) {
switch (ch) {
case 'A':
return 1;
case 'C':
return 2;
case 'G':
return 3;
case 'T':
return 4;
default:
return 0;
}
}

//将字符串转换为数值并生成key
long long get_key(char str[]) {
long long sum = 0, p = 1;
for (int i = 0; i < strlen(str); i++) {
sum += p * (get_char(str[i]));
p *= 5;
}
return sum;
}

int h1(int key) { return key % M; }

int h2(int key) { return 1 + (key % (M - 1)); }

int find(char str[]) {
long long key = get_key(str), h;
for (int i = 0; ; i++) {
h = (h1(key) + i * h2(key)) % M;
if (strcmp(H[h], str) == 0) return 1;
else if (strlen(H[h]) == 0) return 0;
}
}

int insert(char str[]) {
long long key = get_key(str), h;
for (int i = 0; ; i++) {
h = (h1(key) + i * h2(key)) % M;
if (strcmp(H[h], str) == 0) return 1;
else if (strlen(H[h]) == 0) {
strcpy(H[h], str);
return 0;
}
}
}

int main() {
int n;
scanf("%d",&n);
char str[L], com[9];
for (int i = 0; i < M; i++) H[i][0] = '\0';
for (int i = 0; i < n; i++) {
scanf("%s %s",com,str);
if (com[0] == 'i') insert(str);
else {
if (find(str)) printf("yes\n");
else printf("no\n");
}
}
return 0;
}