给定n本书的名称和定价,本题要求编写程序,查找并输出其中定价最高和最低的书的名称和定价。
输入格式:
输入第一行给出正整数n(<10),随后给出n本书的信息。每本书在一行中给出书名,即长度不超过30的字符串,随后一行中给出正实数价格。题目保证没有同样价格的书。
输出格式:
在一行中按照“价格, 书名”的格式先后输出价格最高和最低的书。价格保留2位小数。
输入样例:
3
Programming in C
21.5
Programming in VB
18.5
Programming in Delphi
25.0
输出样例:
25.00, Programming in Delphi
18.50, Programming in VB
#include<stdio.h>
struct type{
double cash;
char name[101];
};
int main(){
int i,n;
struct type s1,max,min;
scanf("%d",&n);
for(i=1;i<=n;i++){
scanf("\n");
gets(s1.name);
scanf("%lf",&s1.cash);
if(i==1)max=min=s1;
if(max.cash<s1.cash)max=s1;
if(min.cash>s1.cash)min=s1;
}
printf("%.2lf, %s\n",max.cash,max.name);
printf("%.2lf, %s",min.cash,min.name);
}
我的结构
struct type{
double cash;
char name[101];
};
在main函数里定义我要用到的数据
struct type s1,max,min;