1115 Counting Nodes in a BST (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where ​​n1​​​ is the number of nodes in the lowest level, ​​n2​​​ is that of the level above, and ​​n​​ is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

 题目大意:输出最低两层的结点数之和

按照BST要求建树 ,然后dfs求每个层次的节点数

//先把树建起来 
#include <bits/stdc++.h>
#define Max 1111
using namespace std;
struct Node{
int data;
struct Node *lchild, *rchild;
};
int n, d;
int sum[Max];
int maxl;
void create(Node *&rt, int data){
if(rt == NULL){
rt = (Node*)malloc(sizeof(Node));
rt->data = data;
rt->lchild = rt->rchild = NULL;
return;
}
if(data <= rt->data){
create(rt->lchild, data);
}else if(data > rt->data){
create(rt->rchild, data);
}
}
void dfs(Node *rt, int l){
if(l > maxl){
maxl = l;
}
sum[l]++;
if(rt->lchild) dfs(rt->lchild, l+1);
if(rt->rchild) dfs(rt->rchild, l+1);
}
int main(){
cin >> n;
Node *rt = NULL;
for(int i = 0; i < n; i++){
cin >> d;
create(rt, d);
}
maxl = -1;
memset(sum, 0, sizeof(sum));
dfs(rt, 1);
// cout << maxl << endl;
cout << sum[maxl] << " + " << sum[maxl - 1] << " = " << sum[maxl] + sum[maxl - 1] << endl;
return 0;
}