1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

PAT 1099 Build A Binary Search Tree (30分)_ci

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format ​​left_index right_index​​, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

 题目大意:给出二叉树结构,和一组数,有且仅有一种方法将数填入到二叉树中,使其变成二叉搜索树,最后要求输出其层序序列

思路:对于二叉搜索树,其中序遍历是递增的,所以把给的一组数排序之后按照中序的规则填入树中

//在已有的二叉树结构中填值,并且输出其层序遍历序列 
#include <bits/stdc++.h>
#define Max 101
using namespace std;
struct Node{
int val;
int lc, rc;
}node[Max];
int n, arr[Max], ind = 0;
vector<int> ans;
void inOrder(int rt) {
if(rt == -1) return;
inOrder(node[rt].lc);
node[rt].val = arr[ind++];
inOrder(node[rt].rc);
}
void levelOrder(int rt) {
queue<int> q;
q.push(rt);
while(!q.empty()) {
int u = q.front();
q.pop();
ans.push_back(node[u].val);
if(node[u].lc != -1) {
q.push(node[u].lc);
}
if(node[u].rc != -1) {
q.push(node[u].rc);
}
}
}
int main() {
cin >> n;
for(int i = 0; i < n; i++) {
cin >> node[i].lc >> node[i].rc;
}
for(int i = 0; i < n; i++)
cin >> arr[i];
sort(arr, arr+n);
inOrder(0); //填值
levelOrder(0); //遍历
for(int i = 0; i < ans.size(); i++)
{
cout << ans[i];
if(i != ans.size() - 1) cout << " ";
else cout << endl;
}
return 0;
}