1115. Counting Nodes in a BST (30)


时间限制



400 ms



内存限制



65536 kB



代码长度限制



16000 B



判题程序



Standard



作者



CHEN, Yue


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.


Sample Input:


9 25 30 42 16 20 20 35 -5 28


Sample Output:


2 + 4 = 6

建立排序二叉树然后求最下面两层的点数。

#include<map>
#include<cstdio>
#include<vector>
#include<cmath>
#include<queue>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int low(int x){ return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int n, cnt[maxn], a[maxn];
int ch[maxn][2], root;

void insert(int &x, int y)
{
if (!x) { x = y; return; }
if (a[y] <= a[x]) insert(ch[x][0], y);
else insert(ch[x][1], y);
}

void dfs(int x, int dep)
{
if (!x) return;
cnt[dep]++;
dfs(ch[x][0], dep + 1);
dfs(ch[x][1], dep + 1);
}

int main()
{
scanf("%d", &n);
for (int i = 1; i <= n; i++)
{
scanf("%d", &a[i]);
insert(root, i);
}
dfs(root, 1);
for (int i = n; i; i--)
{
if (cnt[i])
{
printf("%d + %d = %d\n", cnt[i], cnt[i - 1], cnt[i] + cnt[i - 1]);
break;
}
}
return 0;
}