题目链接
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index
, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
题意:给出一棵二叉搜索树(给出每个结点的左右孩子),且已知根结点为0,求并且给出应该插入这个二叉搜索树的数值,求这棵二叉树的层序遍历
思路:二叉搜索树的中序序列是从小到大排列的序列,所以只需要中序建树,层序遍历即得到答案。
代码:
#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e5+5;
struct Node {
int val,left,right;
};
vector<Node>tree;
vector<int>v;
int cnt=0;
void inOrder(int root) {
if(tree[root].left==-1&&tree[root].right==-1) {
tree[root].val=v[cnt++];
return ;
}
if(tree[root].left!=-1) inOrder(tree[root].left);
tree[root].val=v[cnt++];
if(tree[root].right!=-1) inOrder(tree[root].right);
}
void printLevel() {
queue<int>que;
que.push(0);
printf("%d",tree[0].val);
while(!que.empty()) {
int root=que.front();
que.pop();
if(root) printf(" %d",tree[root].val);
if(tree[root].left!=-1) que.push(tree[root].left);
if(tree[root].right!=-1) que.push(tree[root].right);
}
}
int main() {
int n;
scanf("%d",&n);
tree.resize(n);
v.resize(n);
for(int i=0; i<n; i++) {
scanf("%d%d",&tree[i].left,&tree[i].right);
}
for(int i=0; i<n; i++) {
scanf("%d",&v[i]);
}
sort(v.begin(),v.end());
inOrder(0);
printLevel();
return 0;
}