Doing Homework again


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6942    Accepted Submission(s): 4133

Problem Description


Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.


 


Input


The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.


 


Output


For each test case, you should output the smallest total reduced score, one line per test case.


 


Sample Input


3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4


 


Sample Output


0 3 5


/*
HDU 1789 贪心
第一步按照score从大到小排序,如果score相等,则按照deadline从小到大排。
然后开始选择,让当前的课排在其deadline上面,如果这一天已经被占用了,
那么就往前循环,有位置了就安排,没了就ans+=score。
*/
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 1001
struct work{
int deadLine;
int score;
};
work Q[N];
int vis[N];

bool cmp(work a,work b)
{
if(a.score!=b.score)
return a.score>b.score;
else
return a.deadLine>b.deadLine;
}

int main()
{
int n,i,j,ans,t;

//freopen("test.txt","r",stdin);
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&Q[i].deadLine);
for(i=0;i<n;i++)
scanf("%d",&Q[i].score);
sort(Q,Q+n,cmp);

memset(vis,0,sizeof(vis));
ans=0;
for(i=0;i<n;i++)
{
for(j=Q[i].deadLine;j>=1;j--)
{
if(!vis[j])
{
vis[j]=1;
break;
}
}
if(j<=0)
ans+=Q[i].score;
}
printf("%d\n",ans);
}
return 0;
}