Can you solve this equation?


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8498    Accepted Submission(s): 3924

Problem Description


Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


Input


The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output


For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input


2 100 -4


Sample Output


1.6152 No solution!


/*
hdoj 求方程的解 二分法

*/

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;


double y;

double fun(double x){
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}

double find()
{
double mid,a=0,b=100;
while(b-a>1e-6)
{
mid=(a+b)/2;
if(fun(mid)<y)
a=mid+1e-7;
else
b=mid-1e-7;
}
return (a+b)/2.0;
}

int main()
{
int n;

scanf("%d",&n);
while(n--)
{
scanf("%lf",&y);

if(fun(0)<=y&&y<=fun(100))
printf("%.4lf\n",find());
else
printf("No solution!\n");
}
return 0;
}