A problem is easy



1000 ms  |  内存限制: 65535



3



When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..



NYOJ-216-A problem is easy-2013年10月17日13:57:33_java


One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :



Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?



Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.


Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?


The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11). 输出 For each case, output the number of ways in one line 样例输入

2 1 3

样例输出

0 1


# include<stdio.h>

int main()
{
int i,j,N,T,count;
scanf("%d",&T);
while(T--)
{
count = 0;
scanf("%d",&N);
for(j=2;j*j<=N+1;j++)
if((N+1)%j==0)
count++;
printf("%d\n",count);

}

return 0;
}