cisco-nexus系列交换-vpc

vpc简介:

vpc概述

vpc(virtual PortChannel 虚拟链路聚合),技术允许将连接到两个Nexus系列交换机的物理链路看作为一条逻辑端口聚合链路。

可以连接的设备:nexus2000系列的Fabric Extender(交换机矩阵扩展器),交换机,服务器等其他任何网络设备。

vpc技术可以提供二层多路径选择,让用户可以在有多条路径的情况下增加网络冗余,提示带宽,在多个节点之间实现多条并行路径和对流量进行负载均衡。

vpc包括

启用vpc功能之后,需要创建一个对等体保持活动连接(keepalive link),该连接将发送vpc对等体之间的心跳信息。

vpc域包括:vpc对等体设备(交换机)、vpc对等保持活动链路(心跳线)、vpc对等互联链路和连接到下游设备等的vpc域中的所有PortChannels。每个设备上只能有一个vpc域ID。

vpc优势

  • 允许一个设备跨两个上游设备使用PortChannel
  • 消除生成树协议阻塞端口
  • 提供无循环拓扑
  • 使用所有可用的上行带宽
  • 提供快速收敛,比生成树要快。
  • 提供链路级别的弹性。
  • 帮助确保高可用。

vpc案例

vpc不仅允许switch或者server连接到一对Nexus5000系列交换机创建PortChannel,还可以通过Nexus2000交换机来扩展交换机矩阵。如下图1部署场景在两个cisco上的两个端口之间创建一个vpc。
cisco vpc

图2中的vpc部署场景允许cisco nexus2000系列交换机连接到一对nexus5000系列交换机,并使所有连接处于活动状态。
cisco vpc

除了图1和图2中的两个拓扑之外,还可以在任何支撑PortChannel的设备上使用vpc,以便在设备上连接到一对nexus系列交换机实现弹性和高吞吐量。

VPC概念

  • VPC:vpc是指vpc对等体设备和下游设备之间的组合PortChannel。
  • vpc对等交换:就是组成vpc功能的两个nexus系列交换机,一个设备为主,一个为备。
  • vpc对等连接:用于同步vpc对等设备之间状态的连接。vpc对等链路在两个vpc交换机之间携带控制通信量,还有组播、广播数据通信量。在某些链路故障场景中,还携带单播通信量。对等链路至少是两个10GE接口。
  • vpc域:该域包括vpc对等设备、vpc对等保持活动连接和连接到下游设备的vpc中的所有PortChannels。同时,所有关于vpc的全局配置都关联到vpc域下。
  • vpc对等保持活动连接:对等保持活动连接监视vpc对等交换机的生命力。在vpc对等设备之间发送周期性的保持活动连接。vpc对等活动连接可以是管理接口(MGMT)或交换机虚拟接口(SVI)。不能有数据或同步流量在vpc对等保持活动连接上移动;该连接上的唯一通信量是表明交换机正在操作和运行vpc的消息。(也就是说用于vpc对等活动连接的vlan是完全不能做别的事情的。)本实验用MGMT用作对等活动连接。

vpc配置

  • 启用vpc
  • 创建一个vpc域,并进入vpc-域模式。
  • 配置vpc等等保持活动连接。
  • (可选)配置系统优先级。
  • (可选)配置vp角色优先级
  • 创建vpc对等连接。
  • 将PortChannel加入vpc。

验证vpc配置

Command command description
show feature 查看vpc功能是否启用
show vpc brief 查看vpc简短的信息
show vpc consistency-parameters 显示所有vpc接口上必须一致的参数的状态
show running-config vpc 查看vpc的运行配置信息
show port-channel capacity 显示port-channel数量和有效的port-channel数量
show vpc statistics 查看vpc的统计信息
show vpc peer-keepalive 查看vpc保持活动消息的信息
show vpc role 显示vpc对等设备的状态,本地设备的角色,vpc系统的mac地址和系统优先级,和本地设备的mac地址和优先级

两台vpc设备必须相同的配置参数

  • portchannel模式:
    • on、off、active
  • 对等体port-channel链路速度
  • 对等体双工模式
  • 对等体port-channeltrunk模式的本征vlan
  • stp模式
  • stp的全局设置
    • 桥保护设置
    • 端口类型设置
    • 环路保护设置
  • stp接口设置
    • 端口类型设置
    • 环路保护
    • 根保护
  • qos配置
    • priority flow control(PFC)
    • 严格的优先排队和赤字加权循环(DWRR)
    • 最大传输单元(mtu)

如果没有在设备上启用这些参数,则vpc一致性检查将忽略这些参数。

应该相同的配置参数:

  • mac地址老化计时器
  • 静态mac地址条目
  • 所有访问控制列表acl配置和参数
  • 生成树接口设置
    • 桥协议数据单元(BPDU)过滤器
    • BPDU保护
    • cost
    • 链路类型
    • 优先级
    • vlans(每个vlan的生成树配置)
  • IGMP snooping

VPC配置案例

cisco vpc

n9k-1配置

  1. 配置管理接口ip和默认路由

    n9k-1(config)# interface mgmt 0 
    n9k-1(config-if)# ip add 172.16.2.1/24
    n9k-1(config-if)# vrf context management 
    n9k-1(config-vrf)# ip route 0.0.0.0/0 172.16.2.254 (路由本实验可以忽略)
    n9k-1(config-vrf)# exit
  2. 启用vpc和lacp

    n9k-1(config)# feature vpc
    n9k-1(config)# feature lacp
  3. 创建一个vlan

    n9k-1(config)# vlan 101 
    n9k-1(config-vlan)# exit
  4. 创建vpc域

    n9k-1(config)# vpc domain 1 
  5. 配置vpc角色优先级

    n9k-1(config-vpc-domain)# role priority 100
    Warning: 
    !!:: vPCs will be flapped on current primary vPC switch while attempting role change ::!! 
    Note: 
    --------:: Change will take effect after user has re-initd the vPC peer-link  ::-------- 
  6. 配置对等保持活动链接

    n7k-1(config-vpc-domain)# peer-keepalive destination 172.16.2.2 
    Note: 
    --------:: Management VRF will be used as the default VRF ::--------
  7. 配置vpc对等链路。

    注意:在vpc对等体交换机之间的peer link为trunk时,trunk必须允许所有vpc成员端口所属的vlan。

    n9k-1(config-vpc-domain)# interface ethernet 1/1-2 
    n9k-1(config-if-range)# channel-group 1 mode active 
    n9k-1(config-if-range)# interface port-channel 1
    n9k-1(config-if)# vpc peer-link 
    2018 Nov 29 07:52:50 n9k-1 %$ VDC-1 %$ stp: Please note that spanning tree port type is changed to "network" port type on vPC peer-link. This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP Bridge Assurance (which is enabled by default) is not disabled. 
    n9k-1(config-if)# switchport mode trunk 
    n9k-1(config-if)# switchport trunk allowed vlan 1,101
    n9k-1(config-if)# exit
  8. 配置连接n2k port-channel(这步本实验忽略,因为没有下联n2k,直接互联了一个交换)

    激活fex:
    n9k-1(config)# install feature-set fex 
    n9k-1(config)# feature-set fex 
    n9k-1(config)# fex 101 
    n9k-1(config-fex)# pinning max-links 1
    n9k-1(config-fex)# exit
    
    n9k-1(config)# interface ethernet 1/3-4 
    n9k-1(config-if-range)# channel-group 100 
    n9k-1(config-if-range)# interface port-channel 100
    n9k-1(config-if)# switchport mode fex-fabric 
    n9k-1(config-if)# fex associate 101 
    n9k-1(config-if)# exit
  9. 将下联接口加入vpc

    n9k-1(config)# interface ethernet 1/7
    n9k-1(config-if)# channel-group 10 
    n9k-1(config-if)# interface port-channel 10
    n9k-1(config-if)# vpc 10
    n9k-1(config-if)# switchport access vlan 101
    n9k-1(config-if)# exit

n9k-2配置

  1. 配置管理接口ip和默认路由

    n9k-2(config)# interface mgmt 0 
    n9k-2(config-if)# ip add 172.16.2.2/24
    n9k-2(config-if)# vrf context management 
    n9k-2(config-vrf)# ip route 0.0.0.0/0 172.16.2.254 (路由本实验可以忽略)
    n9k-2(config-vrf)# exit
  2. 启用vpc和lacp

    n9k-2(config)# feature vpc 
    n9k-2(config)# feature lacp 
  3. 创建一个vlan

    n9k-2(config)# vlan 101
    n9k-2(config-vlan)# exit
  4. 创建vpc域

    n9k-2(config)# vpc domain 1 
    2018 Nov 29 08:38:14 n9k-2 %$ VDC-1 %$ %STP-2-VPC_PEERSWITCH_CONFIG_DISABLED: vPC peer-switch configuration is disabled. Please make sure to change spanning tree "bridge" priority as per the recommended guidelines.
  5. 配置vpc角色优先级

    本部忽略,不用配置。
  6. 配置对等保持活动链接

    n9k-2(config-vpc-domain)# peer-keepalive destination 172.16.2.1 
  7. 配置vpc对等链路。

    注意:在vpc对等体交换机之间的peer link为trunk时,trunk必须允许所有vpc成员端口所属的vlan。

    n9k-2(config-vpc-domain)# interface ethernet 1/1-2
    n9k-2(config-if-range)# channel-group 1 mode active 
    n9k-2(config-if-range)# interface port-channel 1 
    n9k-2(config-if)# vpc peer-link 
    2018 Nov 29 08:40:31 n9k-2 %$ VDC-1 %$ stp: Please note that spanning tree port type is changed to "network" port type on vPC peer-link. This will enable spanning tree Bridge Assurance on vPC peer-link provided the STP Bridge Assurance (which is enabled by default) is not disabled. 
    n9k-2(config-if)# switchport mode trunk 
    n9k-2(config-if)# switchport trunk allowed vlan 1,101
    n9k-2(config-if)# exit
  8. 配置连接n2k port-channel (这步本实验忽略,因为没有下联n2k,直接互联了一个交换)

    激活fex:
    n9k-2(config)# install feature-set fex 
    n9k-2(config)# feature-set fex 
    n9k-2(config)# fex 101 
    n9k-1(config-fex)# pinning max-links 1
    n9k-2(config-fex)# exit
    
    n9k-2(config)# interface ethernet 1/3-4 
    n9k-2(config-if-range)# channel-group 100 
    n9k-2(config-if-range)# interface port-channel 100
    n9k-2(config-if)# switchport mode fex-fabric 
    n9k-2(config-if)# fex associate 101 
    n9k-2(config-if)# exit
  9. 将下联接口加入vpc

    n9k-2(config)# interface ethernet 1/7
    n9k-2(config-if)# channel-group 10 
    n9k-2(config-if)# interface port-channel 10
    n9k-2(config-if)# vpc 10
    n9k-2(config-if)# switchport access vlan 101
    n9k-2(config-if)# exit

swi-1配置

swi-1(config)# interface range ethernet 0/0 to 0/1 
swi-1(config-if-range)# channel-group 1 
swi-1(config-if-range)# interface port-channel 1
swi-1(config-if)# switchport access vlan 101
swi-1(config-if)# exit

swi-1配置如下:
interface Port-channel1
 switchport access vlan 101
!
interface Ethernet0/0
 channel-group 1 mode on
!
interface Ethernet0/1
 channel-group 1 mode on

验证vpc配置

N9k-1 的验证

验证对等活动连接:
cisco vpc

show vpc brief

cisco vpc

sh vpc peer-keepalive 

cisco vpc

sh vpc role 

cisco vpc

N9k-2 的验证

cisco vpc

cisco vpc

vpc+HSRP 验证冗余

cisco vpc

配置hsrp

n9k

  1. 激活vlan接口和hsrp功能

    n9k-1(config)# feature interface-vlan 
    n9k-1(config)# feature hsrp 
  2. 配置hsrp

    激活track功能:

    n9k-1(config)# feature tacacs+ 

    配置track:

    n9k-1(config)# track 1 interface ethernet 1/7 line-protocol 
    n9k-1(config-if)# interface vlan 101
    n9k-1(config-if)# ip add 172.16.101.1 255.255.255.0
    n9k-1(config-if)# hsrp version 2
    n9k-1(config-if)# hsrp 101
    n9k-1(config-if-hsrp)# priority 120
    n9k-1(config-if-hsrp)# ip 172.16.101.3 
    n9k-1(config-if-hsrp)# track 1 decrement 11 
    n9k-1(config-if-hsrp)# exit
  3. 配置用于hsrp通信的接口

    n9k-1(config)# interface Ethernet1/4
    n9k-1(config-if)# switchport mode trunk
    n9k-1(config-if)# exit

n9k-2的配置

n9k-2(config)# feature interface-vlan 
n9k-2(config)# feature hsrp 
n9k-2(config)# feature tacacs+ 
n9k-2(config)# track 1 interface ethernet 1/3 line-protocol 
n9k-2(config-track)# exit
n9k-2(config)# interface vlan 101
n9k-2(config-if)# ip add 172.16.101.2 255.255.255.0
n9k-2(config-if)# hsrp version 2
n9k-2(config-if)# hsrp 101
n9k-2(config-if-hsrp)# priority 110
n9k-2(config-if-hsrp)# ip 172.16.101.3
n9k-2(config-if-hsrp)# track 1 decrement 11
n9k-2(config-if-hsrp)# exit
n9k-2(config)# interface Ethernet1/4
n9k-2(config-if)# switchport mode trunk
n9k-2(config-if)# exit

swi-1配置

interface vlan101
ip add 172.16.101.100 255.255.255.0

interface Port-channel1
 switchport access vlan 101
!
interface Ethernet0/0
 channel-group 1 mode on
!
interface Ethernet0/1
 channel-group 1 mode on

 ip route 0.0.0.0/0 172.16.101.3

验证hsrp

n9k:

cisco vpc

cisco vpc

模拟链路中断,网关自动切换,丢包1个

cisco vpc

cisco vpc

修改hsrp优先级,网关自动切换,不丢包

cisco vpc

cisco vpc

vpc+hsrp 生成树,没有block口!

cisco vpc

vpc+hsrp 和 单独hsrp 对比

单独的hsrp实验,这里不再叙述。

1、生成树

hsrp的生成树会阻塞端口,vpc+hsrp则不会。

cisco vpc

2、模拟链路中断

hsrp模拟链路中断,切换网关,丢包3个,比vpc+hsrp收敛慢。切回来的时候和vpc+hsrp是一样的。
cisco vpc

cisco vpc

3、修改优先级

hsrp修改优先级,切换网关,丢包现象和vpc+hsrp收敛一样。

4、链路带宽

vpc+hsrp 实现下联交换或者主机的上联链路带宽增加。