拓扑

Cisco vPC 配置   实验手册_思科


概念

什么是 vPC(virtual port channel),是一个可以跨不同设备的port-channel的技术。它的作用:可以实现网络冗余,可以跨设备进行端口聚合, 增加链路带宽,当链路故障时比生成树协议收敛时间还快。

在传统的网络拓扑中要实现网络的冗余,一般都会使用双链路上连的方式,而这种方式明显有一个环路,在这种拓扑下都会开起生成树协议,这时就会有 一种链路是block状态的。所以这种方式实现冗余,并不会增加网络带宽。如果想用链路聚合方式来做双链路上连到两台不同的设备,port-channel功能又不支持跨设备聚合。还有一个方案是上联的设备做堆叠,但是似乎思科的数据中心设备并不支持堆叠,所以在这种背景下就出现了vPC的概念,和port-channel功能相比区别是:vPC功能解决了传统聚合端 口不能跨设备的问题。和传统跨设备方案相比的区别是:即增强网络冗余又能增加网络带宽。

配置

定义vPC域

NXOS1(config)#feature lacp  //开启lacp特性

NXOS1(config)#feature vpc  //开启vpc特性

NXOS1(config)#vpc domain 200  //定义vPC域

NXOS1(config-vpc-domain)#role priority 1 //强制使成为vPC域的主对等体

 

 

NXOS2(config)#feature lacp

NXOS2(config)#feature vpc

NXOS2(config)#vpc domain 200

建立对等体

为了创建对等存活维持链路,每一台交换机必须配置接口地址,并作为目的地址来接收其它vPC对等体的存活维持消息。该场景使用了交换机的管理接口(以及管理VRF)来生产和接收存活维持消息。在NX-OS中管理口(mgmt0)是对等体存活维持链路的默认端口。

NXOS1(config)#interface mgmt0

NXOS1(config-if)#ip address 10.10.10.10/24  //配置管理口的IP地址

 

NXOS2(config)#interface mgmt0

NXOS2(config-if)#ip address 10.10.10.11/24

 

NXOS1(config)#vpc domain 200

NXOS1(config-vpc-domain)#peer-keepalive destination 10.10.10.11 source 10.10.10.10

 

NXOS2(config)#vpc domain 200

NXOS2(config-vpc-domain)#peer-keepalive destination 10.10.10.10 source 10.10.10.11

Cisco vPC 配置   实验手册_cisco _02

创建对等链路

NXOS1(config)#interface port-channel 200

NXOS1(config-if)#switchport

NXOS1(config-if)#switchport mode trunk

NXOS1(config-if)#vpc peer-link

 

NXOS1(config)#interface ethernet1/1 - 2

NXOS1(config-if)#channel-group 200 force mode active

NXOS1(config-if)#no shutdown

 

NXOS2(config)#interface port-channel 200

NXOS2(config-if)#switchport

NXOS2(config-if)#switchport mode trunk

NXOS2(config-if)#vpc peer-link

 

NXOS2(config)#interface ethernet1/1 - 2

NXOS2(config-if)#channel-group 200 force mode active

NXOS2(config-if)#no shutdown

Cisco vPC 配置   实验手册_vPC_03

Cisco vPC 配置   实验手册_cisco _04


创建vPC

NXOS1(config)#interface port-channel 10

NXOS1(config-if)# switchport

NXOS1(config-if)#switchport mode trunk

NXOS1(config-if)#vpc 10

NXOS1(config)#interface Ethernet1/3 - 4

NXOS1(config-if)#channel-group 10 force mode active

NXOS1(config-if)#no shutdown

 

NXOS2(config)#interface port-channel 10

NXOS2(config-if)# switchport

NXOS2(config-if)#switchport mode trunk

NXOS2(config-if)#vpc 10

NXOS2(config)#interface Ethernet1/5 - 6

NXOS2(config-if)#channel-group 10 force mode active

NXOS2(config-if)#no shutdown

 

NXS03(config)# feature lacp

NXS03(config)#interface port-channel 10

NXOS3(config-if)#switchport

NXOS3(config-if)#switchport mode trunk

NXS03(config)#interface Ethernet1/3 - 6

NXOS3(config-if)#channel-group 10 force mode active

查看相关配置

Cisco vPC 配置   实验手册_思科 _05

Cisco vPC 配置   实验手册_cisco _06

Cisco vPC 配置   实验手册_ 配置_07

Cisco vPC 配置   实验手册_思科 _08

Cisco vPC 配置   实验手册_思科 _09