拓扑图如下:

eigrp_lab2  负载均衡_负载均衡 

配置:

 

R1#interface FastEthernet0/0
 ip address 192.168.14.1 255.255.255.0
delay 2000    //用于验证eigrp支持等价负载均衡                                              

!
interface Serial1/0
 ip address 192.168.

12.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 192.168.12.0
 network 192.168.14.0
 no auto-summary

R2#interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
 interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.23.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 2.0.0.0
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary
!

R3#interface Serial1/0
 ip address 192.168.34.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 192.168.23.2 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 192.168.23.0
 network 192.168.34.0
 no auto-summary

R4#interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.14.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.34.2 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 variance 2  //用于实现eigrp非等价负载均衡
 network 4.0.0.0
 network 192.168.14.0
 network 192.168.34.0
 no auto-summary
 

默认情况下:

metric=【10^7/最小入接口带宽+各个入向接口延迟/10】*256

凡是AD>最小FD的都可以加入到拓扑表中

AD:通告距离,即为邻居到目的网段的metric

FD: 可行距离,即为本地到目的网段的metric

实验目的:

1、验证eigrp支持等价负载均衡(通过修改接口带宽或者延迟使得FD相等,

这样就可以同时加到拓扑表中,相等的最小FD条目就会加到路由表中)

R2

2、支持非等价负载均衡

通过修改差量因子variance

差量因子(x)的计算:最优FD*x>次优FD

差量因子属于1-128其间的一个正整数

默认情况下等于1.