LAB6:EIGRP非等价负载均衡

EIGRP分解试验部分-LAB6:EIGRP非等价负载均衡_分解

使用场合:
每种路由协议都有等价负载均衡的功能,但是EIGRP协议还可以支持非等价负载均衡,当多条链路度量不等的情况下,也可以进行负载,充分利用多条链路。提高传输的效率。
 
基本配置:
R1
interface Ethernet0/0
ip address 13.1.1.1 255.255.255.0
interface Serial1/2
ip address 12.1.1.1 255.255.255.0
router eigrp 1
network 12.1.1.0 0.0.0.255
network 13.1.1.0 0.0.0.255
no auto-summary
R2
interface Serial1/2
ip address 23.1.1.2 255.255.255.0
interface Serial1/3
ip address 12.1.1.2 255.255.255.0
serial restart-delay 0
router eigrp 1
network 12.1.1.0 0.0.0.255
network 23.1.1.0 0.0.0.255
no auto-summary
R3
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Ethernet0/0
ip address 13.1.1.3 255.255.255.0
interface Serial1/3
ip address 23.1.1.3 255.255.255.0
router eigrp 1
network 3.3.3.0 0.0.0.255
network 13.1.1.0 0.0.0.255
network 23.1.1.0 0.0.0.255
no auto-summary
 
R1查看路由情况
R1#show ip route
Gateway of last resort is not set
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/409600] via 13.1.1.3, 00:10:41, Ethernet0/0
23.0.0.0/24 is subnetted, 1 subnets
D 23.1.1.0 [90/2195456] via 13.1.1.3, 00:15:41, Ethernet0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/2
13.0.0.0/24 is subnetted, 1 subnets
C 13.1.1.0 is directly connected, Ethernet0/0
 
查看EIGRP拓扑表,我们发现,3.3.3.0的网络并没有关于从R2走的这条路径。只有
下一跳到R3的。为什么?
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(13.1.1.1)
P 3.3.3.0/24, 1 successors, FD is 179200
via 13.1.1.3 (409600/128256), Ethernet0/0
P 12.1.1.0/24, 1 successors, FD is 2169856
via Connected, Serial1/2
P 13.1.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0
P 23.1.1.0/24, 1 successors, FD is 2195456
via 13.1.1.3 (2195456/2169856), Ethernet0/0
via 12.1.1.2 (2681856/2169856), Serial1/2
我们通过这条命令看到,从R2走的路径的AD>FD 2297856>409600)也就是说要满足FS(可行后继)的条件不够,条件是AD<FD
R1#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(13.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 3.3.3.0/24, 1 successors, FD is 179200, serno 9
via 13.1.1.3 (409600/128256), Ethernet0/0
via 12.1.1.2 (2809856/2297856), Serial1/2
P 12.1.1.0/24, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/2
P 13.1.1.0/24, 1 successors, FD is 281600, serno 8
via Connected, Ethernet0/0
P 23.1.1.0/24, 1 successors, FD is 2195456, serno 5
via 13.1.1.3 (2195456/2169856), Ethernet0/0
via 12.1.1.2 (2681856/2169856), Serial1/2
我们可以通过更改R2的链路的带宽和延迟来影响,使之满足AD<FD.
R2
interface Serial1/2
ip address 23.1.1.2 255.255.255.0
bandwidth 100000
delay 10
 
再次查看R1的拓扑表,出现了2个下一跳
R1#show ip eig topology
IP-EIGRP Topology Table for AS(1)/ID(13.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 3.3.3.0/24, 1 successors, FD is 409600
via 13.1.1.3 (409600/128256), Ethernet0/0
via 12.1.1.2 (2300416/156160), Serial1/2
P 12.1.1.0/24, 1 successors, FD is 2169856
via Connected, Serial1/2
P 13.1.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0
P 23.1.1.0/24, 1 successors, FD is 2172416
via 12.1.1.2 (2172416/28160), Serial1/2
via 13.1.1.3 (2195456/2169856), Ethernet0/0
 
配置R1 的EIGRP 的variance 值
非等价负载均衡:VARIANCE
非等价负载流量分配的方式:选择度量最小路径,选择负载均衡路径 ,用后者的metric 除以前者的metric,有小数就进位,不可舍位.例如结果为3.1.那么配置的时候variance 4.
P 3.3.3.0/24, 1 successors, FD is 409600
via 13.1.1.3 (409600/128256), Ethernet0/0
via 12.1.1.2 (2300416/156160), Serial1/2
2300416/409600=5.61
 
VARIANCE配置为6
R1
router eigrp 1
variance 6
 
再次查看路由表是否出现2个下一跳
R1#show ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/409600] via 13.1.1.3, 00:08:21, Ethernet0/0
[90/2300416] via 12.1.1.2, 00:08:21, Serial1/2
23.0.0.0/24 is subnetted, 1 subnets
D 23.1.1.0 [90/2195456] via 13.1.1.3, 00:08:21, Ethernet0/0
[90/2172416] via 12.1.1.2, 00:08:21, Serial1/2
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback1
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/2
13.0.0.0/24 is subnetted, 1 subnets
C 13.1.1.0 is directly connected, Ethernet0/0