eigrp_lab1_eigrp-默认路由

 

配置如下:

R1#

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 1.1.2.2 255.255.255.0
!
interface Loopback2
 ip address 1.1.3.3 255.255.255.0
!
interface Loopback3
 ip address 1.1.4.4 255.255.255.0
!
interface Loopback9
 ip address 4.4.4.4 255.0.0.0
!
interface Serial1/0
 ip address 172.16.1.1 255.255.255.0
 ip summary-address eigrp 1 1.1.0.0 255.255.252.0 5
 serial restart-delay 0
 router eigrp 1
 network 1.0.0.0
 network 4.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip classless
ip default-network 4.0.0.0
ip route 4.0.0.0 255.0.0.0 4.4.4.0

R2#

interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 172.16.2.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 2.0.0.0
 network 172.16.0.0
 no auto-summary

R3#

interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.2.2 255.255.255.0
!
interface Loopback2
 ip address 192.168.3.3 255.255.255.0
!
interface Serial1/0
 ip address 172.16.2.2 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 172.16.0.0
 network 192.168.0.0 0.0.255.255
 no auto-summary
!

实验目的:

1、eigrp默认时自动汇总是开的,将自动汇总到主类网段

2、支持无类路由间汇总,即在路由器的端口下进行配置手动汇总

ip summary-address eigrp 1 1.1.0.0 255.255.252.0 5(后面出现5的原因是)

如果自动汇总没有关闭的话,首先执行的是手动配置的汇总。

3、通告方式:

。可以直接通告直连主类网段

。通告网段加上反子网掩码(子网掩码也是可以的,系统会自动修改)

4、eigrp添加默认路由

使用ip default-network 主类网段

注意:这里在接口配置对应的ip地址的子网掩码也必须是主类的,eigrp下通告也是

当然还有其他方法。这里就不多说了。

 

EIGRP-show ip eigrp neighbors的解析

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   172.16.1.2              Se1/0         12 00:07:22  198  1188  0  6

H:表示与邻居建立回话的顺序

Adress:邻居路由器的接口地址

Interface:本地到邻居路由器的接口

Hold:认为邻居关系不存在所能等待的最长时间

Uptime:从邻居关系建立到目前的时间

SRTT:是向邻居路由器发送一个数据包到本路由器收到确认包的时间

RTO:路由器在重新传输包之前等到ACK的时间

Q Cnt:等待发送队列

Seq NUM:从邻居收到发送数据包的序列号