要达到两地之间通信,可以用到的技术比较多。常用的如×××,虚拟隧道(Tunnel)实验,虽然在安全性方面比较低,但是还是值得一提、

 

虚拟隧道(Tunnel)技术、实验_隧道 

 

R0:

Router#show running-config
Building configuration...

Current configuration : 638 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 202.102.60.2 255.255.255.0
!
interface Serial0/0/1
 ip address 218.30.1.1 255.255.255.0
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 61.177.7.0 255.255.255.0 218.30.1.2
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

 

R1:

Router#show running-config
Building configuration...

Current configuration : 638 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 61.177.7.1 255.255.255.0
 clock rate 64000
!
interface Serial0/0/1
 ip address 218.30.1.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 202.102.60.0 255.255.255.0 218.30.1.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

R2:

Router#show running-config
Building configuration...

Current configuration : 821 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 ip address 192.168.3.1 255.255.255.0
 tunnel source Serial0/0/0
 tunnel destination 61.177.7.2
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 202.102.60.1 255.255.255.0
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 192.168.1.0
 network 192.168.3.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

R3:

Router#show running-config
Building configuration...

Current configuration : 793 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 ip address 192.168.3.2 255.255.255.0
 tunnel source Serial0/0/0
 tunnel destination 202.102.60.1
!
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 61.177.7.2 255.255.255.0
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 192.168.2.0
 network 192.168.3.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end