DM×××配置实例
DM×××配置实例_DMVPN
 
 
HUB#sh running-config
Building configuration...
Current configuration : 1229 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HUB
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto isakmp policy 10
 authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!        
crypto ipsec transform-set dmvpn esp-des esp-md5-hmac
!
crypto ipsec profile lab
 set transform-set dmvpn
!
!
!
!
!
interface Tunnel0
 ip address 14.1.1.1 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast dynamic
 ip nhrp network-id 123
 no ip split-horizon eigrp 10
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 123
 tunnel protection ipsec profile lab
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex half
!
router eigrp 10
 network 1.1.1.0 0.0.0.255
 network 14.1.1.0 0.0.0.255
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!        
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end
Router#sh running-config
Building configuration...
Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto isakmp policy 10
 authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!        
crypto ipsec transform-set dmvpn esp-des esp-md5-hmac
!
crypto ipsec profile lab
 set transform-set dmvpn
!
!
!
!
!
interface Tunnel0
 ip address 14.1.1.4 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map 14.1.1.1 10.0.0.1
 ip nhrp map multicast 10.0.0.1
 ip nhrp network-id 123
 ip nhrp nhs 14.1.1.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 123
 tunnel protection ipsec profile lab
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex half
!
router eigrp 10
 passive-interface Loopback0
 network 4.4.4.0 0.0.0.255
 network 14.1.1.0 0.0.0.255
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end
 
Router#sh running-config
Building configuration...
Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto isakmp policy 10
 authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
!        
crypto ipsec transform-set dmvpn esp-des esp-md5-hmac
!
crypto ipsec profile lab
 set transform-set dmvpn
!
!
!
!
!
interface Tunnel0
 ip address 14.1.1.6 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map 14.1.1.1 10.0.0.1
 ip nhrp map multicast 10.0.0.1
 ip nhrp network-id 123
 ip nhrp nhs 14.1.1.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 123
 tunnel protection ipsec profile lab
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.3 255.255.255.0
 duplex half
!
router eigrp 10
 passive-interface Loopback0
 network 6.6.6.0 0.0.0.255
 network 14.1.1.0 0.0.0.255
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end
 
HUB#sh crypto isakmp sa
dst             src             state          conn-id slot status
10.0.0.1        10.0.0.2        QM_IDLE              1    0 ACTIVE
10.0.0.1        10.0.0.3        QM_IDLE              2    0 ACTIVE
 
HUB#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     4.0.0.0/24 is subnetted, 1 subnets
D       4.4.4.0 [90/297372416] via 14.1.1.4, 00:06:29, Tunnel0
     6.0.0.0/24 is subnetted, 1 subnets
D       6.6.6.0 [90/297372416] via 14.1.1.6, 00:01:51, Tunnel0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.1.1.0 is directly connected, Tunnel0
 
Router#sh crypto isakmp sa
dst             src             state          conn-id slot status
10.0.0.1        10.0.0.2        QM_IDLE              1    0 ACTIVE

Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/297372416] via 14.1.1.1, 00:07:16, Tunnel0
     4.0.0.0/24 is subnetted, 1 subnets
C       4.4.4.0 is directly connected, Loopback0
     6.0.0.0/24 is subnetted, 1 subnets
D       6.6.6.0 [90/310172416] via 14.1.1.1, 00:02:24, Tunnel0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.1.1.0 is directly connected, Tunnel0
 
Router#sh crypto isakmp sa
dst             src             state          conn-id slot status
10.0.0.1        10.0.0.3        QM_IDLE              1    0 ACTIVE
 
Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/297372416] via 14.1.1.1, 00:03:04, Tunnel0
     4.0.0.0/24 is subnetted, 1 subnets
D       4.4.4.0 [90/310172416] via 14.1.1.1, 00:03:04, Tunnel0
     6.0.0.0/24 is subnetted, 1 subnets
C       6.6.6.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.1.1.0 is directly connected, Tunnel0