Router#
Router#sh run      
Building configuration...
 
Current configuration:
!
service timestamps log date
service timestamps debug date
no service password-encryption
!
!
ip domain name-server address 202.109.15.135
!
!
!
!
gbsc group default
!
!
!
!
!
aaa authentication login default local
aaa authentication enable default none
aaa authentication ppp default local
!
username admin password 0 admin
!
crypto identification bdcom
 fqdn "dlink800.vicp.net"
!
!
crypto isakmp key bdcom zlyone.vicp.net
!
!
crypto isakmp policy 111
 hash md5
 lifetime 28800
!
crypto ipsec transform-set myset
!
crypto map mymap 10 ipsec-isakmp
 mode aggressive
 id bdcom
 set peer zlyone.vicp.net
 set transform-set myset
 match address vpn
!
!
interface Virtual-tunnel0
 mtu 1492
 ip address negotiated
 no ip directed-broadcast
 crypto map mymap
 ppp chap hostname ad51520876
 ppp chap password 0 FAffmYSp
 ppp pap sent-username ad51520876 password 0 FAffmYSp
 ip nat outside
 ip nat mss 1452
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 ip fast-switch enable
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip address 192.168.2.1 255.255.255.0 secondary
 no ip directed-broadcast
 ip nat inside
 ip fast-switch enable
!
!
ip domain ddns vendor 11 peanuthull
 server phservice5.oray.net
 username asu800
 password dlink800
 port 6060
 bind dlink800.vicp.net interface vn0
 enable
!
!
!
ip route default Virtual-tunnel0
!
!
!
!
ip access-list extended nat
 deny   ip 192.168.1.0 255.255.255.0 192.168.0.1 255.255.255.0
 permit ip any any
!
ip access-list extended vpn
 permit ip 192.168.1.0 255.255.255.0 192.168.0.0 255.255.255.0
!
!
!        
vpdn enable
!
vpdn-group poe0
 request-dialin
 port Virtual-tunnel0
 protocol pppoe
 pppoe bind FastEthernet0/0
!
!
!
ip http server
ip http language chinese
ip http timeout 10
!
!
ip nat inside source list nat interface Virtual-tunnel0
!
Router#