shǎ崽 OrOrOrOrz

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3630    Accepted Submission(s): 1683

Problem Description
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen . 
For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
 

 

Input
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
 

 

Output
Output a sequence of distinct integers described above.
 

 

Sample Input
5 1 2 3 4 5
 

 

Sample Output
5 1 4 2 3
 

 

Author
WhereIsHeroFrom
 

 

Source
 

 

Recommend
lcy
 

 

解题代码

#include<stdio.h>

#include<stdlib.h>


int comp(const void *a,const void *b) {

return *(int *)a-*(int *)b;

}


int main() {

int a[10000];

int i,n;

while(scanf("%d",&i)!=EOF) {

for(n=0;n<i;n++)

scanf("%d",&a[n]);

qsort(a,i,sizeof(int),comp);

for(n=0;n<i/2;n++)

printf(n==i/2-1&&i%2==0?"%d %d\n":"%d %d ",a[i-n-1],a[n]);

if(i%2!=0) printf("%d\n",a[i/2]);

}

return 0;

}

 

解题思路:

    先用快排排序,然后倒正相反同时输出,本体最主要小难点在在偶数和奇数控制输出上,即控制空格输出,然后换行,祝你好运