前几天,接了个做无线的项目。他们呢, 已经有现有的有线网络,目前还在改造中,需要将无线和有线一起暂时先用着,只需要将无线开通就可以了!他们选的设备是无线控制air-ct2504-k9,无线ap air-lap1041n-e-k9,POE供电交换机为cisco 2960pc-l 。控制器ios版本 7.3.101.0

   起初的设想将控制器,ap以及poe全部都放在现有的有线网段,因为对无线还是一知半解,不知道可行不,就开始配置起来,后来发现不行,所有的ap不能关联到控制器上。配置错误

   然后做出了第二种方法,将ap,交换机和控制器管理划分在一个vlan中,然后让控制器去关联到有限网络的vlan中,其中配置如下:

  (1)poe上的配置:poe#sh run
Building configuration...

Current configuration : 6235 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname poe
!
boot-start-marker
boot-end-marker
!

ip dhcp excluded-address 172.30.1.1 172.30.1.200
!
ip dhcp pool wifi
  network 172.30.1.0 255.255.255.0
  default-router 172.30.1.125
!
!
no ip domain-lookup
!

!
interface FastEthernet0/1
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!        
interface FastEthernet0/2
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/3
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/4
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/5
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/6
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/7
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/8
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/9
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/10
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/11
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/12
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/13
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/14
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/15
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/16
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/17
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/18
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/19
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/20
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/21
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/22
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/23
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/24
switchport trunk native vlan 10
switchport mode trunk
spanning-tree portfast trunk
!        
interface GigabitEthernet0/1
switchport mode trunk
ip dhcp snooping trust
!
interface GigabitEthernet0/2
switchport mode trunk
ip dhcp snooping trust
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan10
ip address 172.30.1.6 255.255.255.0
no ip route-cache
!
ip default-gateway 172.30.1.125
ip http server
ip http secure-server
!
line con 0
login local
line vty 0 4
login local
line vty 5 15
login local
!
end

//配置了一个vlan,接口配置为trunk,配置了一个dhcp地址池

**********************************************************

(2)核心交换机的配置:

Core-5750#sh run  

Building configuration...
Current configuration : 1797 bytes

!
version RGOS 10.4(2b12) Release(154722)(Wed Mar  6 11:19:50 CST 2013 -ngcf61)
hostname Core-5750
!
!
nfpp
no arp-guard enable
!
!
vlan 1
!
vlan 10
!
!

service dhcp
no ip dhcp snooping vlan 10
ip dhcp snooping
!
!

interface GigabitEthernet 0/1
switchport mode trunk
ip dhcp snooping trust
!
interface GigabitEthernet 0/2
!
interface GigabitEthernet 0/3
!
interface GigabitEthernet 0/4
!
interface GigabitEthernet 0/5
!        
interface GigabitEthernet 0/6
!
interface GigabitEthernet 0/7
!
interface GigabitEthernet 0/8
!
interface GigabitEthernet 0/9
!
interface GigabitEthernet 0/10
!
interface GigabitEthernet 0/11
!
interface GigabitEthernet 0/12
!
interface GigabitEthernet 0/13
!
interface GigabitEthernet 0/14
!
interface GigabitEthernet 0/15
!
interface GigabitEthernet 0/16
!
interface GigabitEthernet 0/17
!        
interface GigabitEthernet 0/18
!
interface GigabitEthernet 0/19
switchport access vlan 10
description to-pc
!
interface GigabitEthernet 0/20
!
interface GigabitEthernet 0/21
!
interface GigabitEthernet 0/22
switchport mode trunk
ip dhcp snooping trust
ip arp inspection trust
!
interface GigabitEthernet 0/23
switchport mode trunk
ip dhcp snooping trust
ip arp inspection trust
description to_ac
!
interface GigabitEthernet 0/24
!
interface GigabitEthernet 0/25
!
interface GigabitEthernet 0/26
!
interface GigabitEthernet 0/27
!
interface GigabitEthernet 0/28
!
interface VLAN 10
no ip proxy-arp
ip address 172.30.1.2 255.255.255.0
!
!
ip route 0.0.0.0 0.0.0.0 172.30.1.1
!
!
line con 0
line vty 0 4
login local
!
!
end

//配置接口信息

*****************************************************

(2)控制器上配置了management地址,跟poe交换机vlan10在同一网段。测试连通性,都能够通信,此时在web上打开控制器页面后,新建一个接口地址属于有线上网段的地址时候,页面就无响应了。

 后来查看pc上的arp表的时候,发现控制器上的mac地址上分配了2个ip地址,

 最后的解决方案是从网关上做了一条映射,从外网远程配置的,这个问题还是没能解决!