实验拓扑图如下:
 
 子接口实现帧中继_帧中继

 
实验步骤
(一)、基本信息配置
1)、RT1的基本信息配置:
RT1-FRSW#enable
RT1-FRSW#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT1-FRSW(config)#hostname RT1-FRSW
RT1-FRSW(config)#line console 0
RT1-FRSW(config-line)#logging synchronous
RT1-FRSW(config-line)#no login
RT1-FRSW(config-line)#privilege level 15
RT1-FRSW(config-line)#exit
RT1-FRSW(config)#line vty 0 4
RT1-FRSW(config-line)#no login
RT1-FRSW(config-line)#privilege level 15
 
2)、RT3的基本信息配置:
RT5#enable
RT5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT5(config)#hostname RT3
RT3(config)#line console 0
RT3(config-line)#logging synchronous
RT3(config-line)#no login
RT3(config-line)#privilege level 15
RT3(config-line)#exit
RT3(config)#line vty 0 4
RT3(config-line)#no login
RT3(config-line)#privilege level 15
RT3(config-line)#
 
3)、RT5的基本信息配置:
RT5#enable
RT5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT5(config)#hostname RT5
RT5(config)#line console 0
RT5(config-line)#logging synchronous
RT5(config-line)#no login
RT5(config-line)#privilege level 15
RT5(config-line)#exit
RT5(config)#line vty 0 4
RT5(config-line)#no login
RT5(config-line)#privilege level 15
RT5(config-line)#
 
4)、RT7的基本信息配置:
Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RT7
RT7(config)#line console 0
RT7(config-line)#logging synchronous
RT7(config-line)#no login
RT7(config-line)#privilege level 15
RT7(config-line)#exit
RT7(config)#line vty 0 4
RT7(config-line)#no login
RT7(config-line)#privilege level 15
RT7(config-line)#
 
 
5)、帧中继交换机配置
RT1-FRSW(config)#frame-relay switching             //启动帧中继交换
RT1-FRSW(config)#int s0/0
RT1-FRSW(config-if)#clock rate 1000000            //DCE端配置时钟速率
%Clockrate bestfitted (rounded) to 1008000
RT1-FRSW(config-if)#encapsulation frame-relay ietf //配置帧中继封装
RT1-FRSW(config-if)#frame-relay lmi-type q933a        //配置LMI类型
RT1-FRSW(config-if)#frame-relay intf-type dce    //配置帧中继接口类型
RT1-FRSW(config-if)#frame-relay route 101 int s0/2 201
                        //配置帧中继路由:定义S0/0—S0/2的PVC
RT1-FRSW(config-if)#frame-relay route 102 int s0/3 202
                            //配置帧中继路由:定义S0/0—S0/2的PVC
RT1-FRSW(config-if)#no shut
RT1-FRSW(config-if)#exit
RT1-FRSW(config)#int s0/2
RT1-FRSW(config-if)#clock rate 1000000           //DCE端配置时钟速率
%Clockrate bestfitted (rounded) to 1008000
RT1-FRSW(config-if)#encapsulation frame-relay ietf
RT1-FRSW(config-if)#frame-relay lmi-type q933a
RT1-FRSW(config-if)#frame-relay intf-type dce
RT1-FRSW(config-if)#frame-relay route 201 int s0/0 101
RT1-FRSW(config-if)#no shut
RT1-FRSW(config)#int s0/3
RT1-FRSW(config-if)#clock rate 1000000            //DCE端配置时钟速率
%Clockrate bestfitted (rounded) to 1008000
RT1-FRSW(config-if)#encapsulation frame-relay ietf
RT1-FRSW(config-if)#frame-relay lmi-type q933a
RT1-FRSW(config-if)#frame-relay intf-type dce
RT1-FRSW(config-if)#frame-relay route 202 int s0/0 102
RT1-FRSW(config-if)#no shut
RT1-FRSW(config-if)#
*Mar 1 00:21:02.583: %LINK-3-UPDOWN: Interface Serial0/3, changed state to up
RT1-FRSW(config-if)#end
 
查看帧中继路由表
RT1-FRSW#sh frame-relay route             //查看RT1上的帧中继路由表
结果如下:
子接口实现帧中继_帧中继_02
    
(二)、接口配置及链路测试
1)、RT3的局域网接口配置
RT3(config)#int et3/0
RT3(config-if)#ip add 192.168.10.1 255.255.255.0
RT3(config-if)#no keepalive        
//Cisco路由器的以太网接口如果没有接网线时,可采用no keepalive使接口up
//Cisco路由器的以太网接口接了网线时,必须配置成默认的keepalive。
RT3(config-if)#no shut
2)、RT5的局域网接口配置
RT5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT5(config)#int et3/0
RT5(config-if)#ip add 192.168.18.1 255.255.255.0
RT3(config-if)#no keepalive
RT5(config-if)#no shut
3)、RT7的局域网接口配置
RT7#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT7(config)#int et3/0
RT7(config-if)#ip add 192.168.22.1 255.255.255.0
RT3(config-if)#no keepalive
RT7(config-if)#no shut
RT7(config-if)#
 
4)、RT3的Frame-Relay点对点子接口配置
RT3(config)#int s0/0
RT3(config-if)#encapsulation frame-relay ietf
//主接口封装帧中继,帧中继封装类型与相连的帧中继交换机接口一致
RT3(config-if)#frame-relay lmi-type q933a
//主接口配置帧中继LMI,帧中继LMI类型与相连的帧中继交换机接口一致
RT3(config-if)#no shut
RT3(config-if)#exit
RT3(config)#int s 0/0.101 point-to-point           //创建点对点子接口
RT3(config-subif)#frame-relay interface-dlci 101 //配置子接口DLCI号
RT3(config-fr-dlci)#exit
RT3(config-subif)#ip add 192.168.1.1 255.255.255.252
RT3(config-subif)#no shut
RT3(config-subif)#exit
RT3(config)#int s0/0.102 point-to-point
RT3(config-subif)#frame-relay interface-dlci 102
RT3(config-fr-dlci)#exit
RT3(config-subif)#ip add 192.168.1.5 255.255.255.252
RT3(config-subif)#no shut
 
5)、RT5的Frame-Relay点对点子接口配置
RT5(config)#int s0/0
RT5(config-if)#encapsulation frame-relay ietf      //主接口封装帧中继
RT5(config-if)#frame-relay lmi-type q933a       //主接口配置帧中继LMI
RT5(config-if)#no shut
RT5(config-if)#exit
RT5(config)#int s0/0.201 point-to-point            //创建点对点子接口
RT5(config-subif)#frame-relay interface-dlci 201 //配置子接口DLCI号
RT5(config-fr-dlci)#exit
RT5(config-subif)#ip add 192.168.1.2 255.255.255.252
RT5(config-subif)#no shut
RT5(config-subif)#END
6)、RT7的Frame-Relay点对点子接口配置
RT7(config)#int s0/0
RT7(config-if)#encapsulation frame-relay ietf      //主接口封装帧中继
RT7(config-if)#frame-relay lmi-type q933a       //主接口配置帧中继LMI
RT7(config-if)#no shut
RT7(config-if)#exit
RT7(config)#int s0/0.202 point-to-point          //创建点对点子接口
RT7(config-subif)#frame-relay interface-dlci 202 //配置子接口DLCI号
RT7(config-fr-dlci)#exit
RT7(config-subif)#ip add 192.168.1.6 255.255.255.252
RT7(config-subif)#no shut
RT7(config-subif)#end
查看帧中继路由表,结果如下所示:
子接口实现帧中继_休闲_03
     可以看出此时配置的PVC都处于活跃状态。
 
(三)、查看帧中继映射表
RT3的帧中继映射表如下:
子接口实现帧中继_职场_04
RT5的帧中继映射表如下:
子接口实现帧中继_休闲_05
RT7的帧中继映射表如下:
子接口实现帧中继_休闲_06
查看帧中继PVC状态后
发现RT3上有两条活跃的PVC,RT5上有一条活跃的PVC,RT7上有一条活跃的PVC。
子接口链路调测
将虚电路两端互ping,都能ping通进一步证实了在整个拓扑中所配置的两条虚电路是活跃的。
 
(六)、配置静态路由
1)、在RT3上为RT5、RT7的业务网段配置静态路由
RT3(config)#ip route 192.168.18.0 255.255.255.0 192.168.1.2
RT3(config)#ip route 192.168.22.0 255.255.255.0 192.168.1.6
RT3#show ip route                //查看RT3的路由表,结果如下:
子接口实现帧中继_职场_07
从路由表中看出在RT3上手动配置了两条静态路由
2)、在RT5上为RT3、RT7的业务网段配置静态路由
RT5(config)#ip route 192.168.10.0 255.255.255.0 192.168.1.1
RT5(config)#ip route 192.168.22.0 255.255.255.0 192.168.1.1
RT5#show ip route                //查看RT5的路由表,结果如下:
子接口实现帧中继_职场_08
    从路由表中看出在RT3上手动配置了两条静态路由
3)、在RT7上为RT3、RT7、5的业务网段配置静态路由
RT7(config)#ip route 192.168.10.0 255.255.255.0 192.168.1.5
RT7(config)#ip route 192.168.18.0 255.255.255.0 192.168.1.5
RT7#show ip route                //查看RT7的路由表,结果如下:
 子接口实现帧中继_子接口_09

 
从路由表中看出在RT7上手动配置了两条静态路由
 
实验验证
RT3pingRT5不能ping通,但后面加上了source192.168.10.1后,就能ping通。
在第六步中已经查看了路由表,三个路由器之间都有去往对方的路由条目,那为什么没有加source以及后面的内容它们就不通呢?
   主要的原因是如果后面不加source以及后面的内容,则收到数据的路由器会以源路由器的出接口作为目的IP来封装数据,但这个路由器又没有去往源路由器出接口的路由,所以封装不了数据,结果造成ping不通。
 
三、实验体会
在本实验中要掌握的知识点有:
1)、帧中继交换机的配置。
2)、帧中继路由的配置及命令的含义。
本实验中要注意的地方有:
1)、广域网链路采用DCE—DTE的背对背连接,DCE端需要配置时钟速率,要先配置DCE端的时钟速率,在配置DCE端的其他配置,然后在配置DTE端;尤其要注意的是先no shutdown DCE端,在no shutdown DTE端,顺序不能颠倒,否则接口将不能up。如果出现问题,同时shutdown DCE端和DTE端,然后重新配置DCE端的时钟速率,再no shutdown DCE端,然后在no shutdown DTE端。
2)、路由器发送数据会以出接口作为数据的源IP地址。