畅通工程续


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32650    Accepted Submission(s): 11927



Problem Description


某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。


 



Input


本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。


 



Output


对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.


 



Sample Input


3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2


 



Sample Output


2 -1


 



Author


linle


 



Source


2008浙大研究生复试热身赛(2)——全真模拟


题目分析:spfa模板题
 

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#define MAX 207

using namespace std;

int n,m;

struct Edge
{
    int v,w,next;
}e[MAX*MAX];

int head[MAX];
int cc;

void add ( int u , int v , int w )
{
    e[cc].v = v;
    e[cc].w = w;
    e[cc].next = head[u];
    head[u] = cc++;
}

bool used[MAX];
int dis[MAX];
int cnt[MAX];

bool spfa ( int s , int d )
{
    memset ( used , false , sizeof ( used ) );
    memset ( dis , -1 , sizeof ( dis ) );
    memset ( cnt , 0 ,sizeof ( cnt ) );
    queue<int> q;
    q.push ( s );
    cnt[s]++;
    used[s] = true;
    dis[s] = 0;
    while ( !q.empty())
    {
        int u = q.front();
        q.pop ( );
        used[u] = false;
        for ( int i = head[u] ; ~i ; i = e[i].next )
        {
            int v = e[i].v;
            if ( dis[v] != -1 && dis[v] <= dis[u] + e[i].w ) continue;
            dis[v] = dis[u] + e[i].w;
            if ( used[v] ) continue;
            used[v] = true;
            q.push ( v );
            if ( ++cnt[v] > n ) return false;
        }
    }
    return true;
}

int main ( )
{
    int u , v , w;
    while ( ~scanf ( "%d%d" , &n , &m )  )
    {
        memset ( head ,-1 ,sizeof ( head ) );
        cc = 0;
        for ( int i = 0 ; i < m ; i++ )
        {
            scanf ( "%d%d%d" , &u , &v , &w );
            add ( u , v , w );
            add ( v , u , w );
        }
        scanf ( "%d%d" , &u , &v );
        if ( spfa ( u , v ) )
            printf ( "%d\n" , dis[v] );
    }
}