畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35206    Accepted Submission(s): 12877

Problem Description

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

 

Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

 


Sample Input

3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2

 

Sample Output

2 -1


Author

linle

Source

Recommend

lcy   |   We have carefully selected several similar problems for you:   ​​2112​​​  ​​​1217​​​  ​​​1142​​​  ​​​1690​​​  ​​​1548​​ 

 


​Statistic​​ | 

​Submit​​ | 

​Discuss​​ | 

​Note​


dijkstr算法,做过好多这样的题了,也解释了那么多。。。这个就不详细说了吧..........

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
struct node//实现优先队列的结构体
{
int pos,cost;
friend bool operator<(node x,node y)
{
return x.cost>y.cost;
}
};
priority_queue<node>s;
int map[205][205],vis[205],n,m;
int dijkstra(int st,int ed)
{
node temp,temp1;
temp.pos=st,temp.cost=0;
s.push(temp);
while(!s.empty())
{
temp1=temp=s.top();
s.pop();
if(temp.pos==ed)
break;
vis[temp.pos]=1;
for(int i=0;i<n;i++)
{
if(!vis[i]&&map[temp.pos][i]<100000)
{
temp.cost=temp.cost+map[temp.pos][i];
temp.pos=i;
s.push(temp);
}
temp=temp1;
}
}
if(temp.pos==ed)
return temp.cost;
else
return -1;
}
int main()
{
while(scanf("%d %d",&n,&m)!=EOF)
{
memset(map,100,sizeof(map));
memset(vis,0,sizeof(vis));
while(!s.empty())
s.pop();
for(int i=0;i<m;i++)
{
int a,b,x;
scanf("%d %d %d",&a,&b,&x);
if(map[a][b]>x)
map[a][b]=map[b][a]=x;
}
int st,ed;
scanf("%d %d",&st,&ed);
printf("%d\n",dijkstra(st,ed));
}
return 0;
}