550 - Multiplying by Rotation
Time limit: 3.000 seconds
Warning: Not all numbers in this problem are decimal numbers!
Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.
Example: 179487 * 4 = 717948
Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:
17 * 4 = 71 (base 9)
as (9 * 1 + 7) * 4 = 7 * 9 + 1
Input
The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.
Output
Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.
Sample Input
10 7 4 9 7 4 17 14 12
Sample Output
6 2 4
学英语:
the least significant digit of the first factor
第一个乘数的最低有效位(即最低位)
思路:不断地将两个最低位a,b相乘计算直到进位为a
解释下最后一个样例的4是怎么算出来的:
完整代码:
/*0.028s*/
#include<cstdio>
int main()
{
int base, fin, a, b, c, count, ans;
while (~scanf("%d%d%d", &base, &fin, &b))
{
a = fin;
c = count = 0;
do
{
ans = a * b + c;
a = ans % base, c = ans / base;
++count;
}
while (ans != fin);
printf("%d\n", count);
}
return 0;
}