494 - Kindergarten Counting Game

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=94&page=show_problem&problem=435

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input


Meep Meep! I tot I taw a putty tat. I did! I did! I did taw a putty tat. Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...


Sample Output


2 7 10 9



只要两个单词以非字母字符隔开,就算两个单词。


完整代码:

/*0.009s*/

#include<cstdio>
#include<cstring>
#include<cctype>

char str[300];

int main(void)
{
	int i, cnt;
	bool hasalpha;
	while (gets(str))
	{
		cnt = 0;
		hasalpha = false;
		for (i = 0; str[i]; i++)
		{
			if (isalpha(str[i]))
			{
				if (!hasalpha)
				{
					++cnt;
					hasalpha = true;
				}
			}
			else
			{
				if (hasalpha)
					hasalpha = false;
			}
		}
		printf("%d\n", cnt);
	}
	return 0;
}