题目:

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I

Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

input

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.

Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

input

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

    The equal sign (`=') will never occur in an other context than within a data field.
    There is no whitespace (tabs,blanks) inside a data field.
    Either P and U, P and I, or U and I will be given.

output

For each test case, print three lines:

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

sample input

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

sample output

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V


题解:根据物理公式 P = U * I 来做,注意单位,如果有m要乘0.001,M要乘1000000,k要乘1000,输出每行后有空行。

代码写的冗长了。。。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

string sp, su, si, str;
char prei, preu, prep;
double ans;
int flag1, flag2, flag3;

void fun(char c, int a){
	int num = a + 2;
	while(1){
		if((str[num] >= '0' && str[num] <= '9') || str[num] == '.'){
			if(c == 'I')
				si += str[num++];
			if(c == 'U')
				su += str[num++];
			if(c == 'P')
				sp += str[num++];
		}
		else if(str[num] == 'm' || str[num] == 'k' || str[num] == 'M'){
				if(c == 'I')
					prei = str[num++];
				if(c == 'U')
					preu = str[num++];
				if(c == 'P')
					prep = str[num++];
		}
		else
			break;
	}
}

void count(){
	double sI, sU, sP;
	sI = sU = sP = 0;
	double num = 1;
	int i, j;
	if (si != ""){
		for (i = 0; i < si.size(); i++)
			if (si[i] == '.')
				break;
		if (i != si.size()){
			for (j = i - 1; j >= 0; j--){
				sI += (si[j] - '0') * num;
				num *= 10;
			}
			num = 0.1;
			for(j = i + 1; j < si.size(); j++){
				sI += (si[j] - '0') * num;
				num /= 10;
			}
			num = 1;
		}
		else {
			for(j = si.size() - 1; j >= 0; j--){
				sI += (si[j] - '0') * num;
				num *= 10;
			}
			num = 1;
		}
		if(prei == 'm')
			sI /= 1000;
		if(prei == 'k')
			sI *= 1000;
		if(prei == 'M')
			sI *= 1000000;
	}
	if (su != ""){
		for (i = 0; i < su.size(); i++)
			if (su[i] == '.')
				break;
		if (i != su.size()){
			for (j = i - 1; j >= 0; j--){
				sU += (su[j] - '0') * num;
				num *= 10;
			}
			num = 0.1;
			for(j = i + 1; j < su.size(); j++){
				sU += (su[j] - '0') * num;
				num /= 10;
			}
			num = 1;
		}
		else {
			for(j = su.size() - 1; j >= 0; j--){
				sU += (su[j] - '0') * num;
				num *= 10;
			}
			num = 1;
		}
		if(preu == 'm')
			sU /= 1000;
		if(preu == 'k')
			sU *= 1000;
		if(preu == 'M')
			sU *= 1000000;
	}
	if (sp != ""){
		for (i = 0; i < sp.size(); i++)
			if (sp[i] == '.')
				break;
		if (i != sp.size()){
			for (j = i - 1; j >= 0; j--){
				sP += (sp[j] -'0') * num;
				num *= 10;
			}
			num = 0.1;
			for(j = i + 1; j < sp.size(); j++){
				sP += (sp[j] - '0') * num;
				num /= 10;
			}
			num = 1;
		}
		else {
			for(j = sp.size() - 1; j >= 0; j--){
				sP += (sp[j] - '0') * num;
				num *= 10;
			}
			num = 1;
		}
		if(prep == 'm')
			sP /= 1000;
		if(prep == 'k')
			sP *= 1000;
		if(prep == 'M')
			sP *= 1000000;
	}
	if(si != "" && su != ""){
		ans = sI * sU;
		flag3 = 1;
	}
	if(si != "" && sp != ""){
		ans = sP / sI;
		flag2 = 1;
	}
	if(su != "" && sp != ""){
		ans = sP / sU;
		flag1 = 1;
	}
}

int main(){
	int cases, i, j, t = 0;
	scanf("%d", &cases);
	getchar();
	while (cases--){
		t++;
		sp = su = si = str = "";
		flag1 = flag2 = flag3 = ans = 0;
		prei = preu = prep = 'a';
		getline(cin, str);
		int length = str.size();
		for (i = 0; i < length; i++){
			if (str[i] == 'I' && str[i + 1] == '=')
				fun('I', i);
			else if (str[i] == 'U' && str[i + 1] == '=')
				fun('U', i);
			else if (str[i] == 'P' && str[i + 1] == '=')
				fun('P', i);
		}
		count();
		printf("Problem #%d\n", t);
		if(flag1 == 1)
			printf("I=%.2lfA\n", ans);
		if(flag2 == 1)
			printf("U=%.2lfV\n", ans);
		if(flag3 == 1)
			printf("P=%.2lfW\n", ans);
		cout << endl;
	}
	return 0;
}