10340 - All in All
Time limit: 3.000 seconds
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input Specification
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.
Output Specification
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
water.
完整代码:
/*0.013s*/
#include<cstdio>
char s[100001], ss[100001];
int main(void)
{
while (~scanf("%s%s", s, ss))
{
int j = 0;
for (int i = 0; ss[i] && s[j]; ++i)///注意判断的技巧~
if (ss[i] == s[j])
++j;
puts(s[j] ? "No" : "Yes");///没读到'\0'就不行~
}
return 0;
}