All in All


Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 27328

 

Accepted: 11175


Description


You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 


Input


The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.


Output


For each test case output "Yes", if s is a subsequence of t,otherwise output "No".


Sample Input


sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter


Sample Output


Yes No Yes No


Source


Ulm Local 2002


#include<stdio.h> 
 
 #include<string.h> 
 
 char a[1000100],b[10000010]; 
 
 int main() 
 
 { 
 
     int n = 0,i,j; 
 
     int m; 
 
     while(scanf("%s%s",&b,&a)!=EOF) 
 
     { 
 
         n = 0; 
 
         n = strlen(b); 
 
         j = 0; 
 
         for(i=0;a[i]!='\0';i++) 
 
         { 
 
             if(a[i] == b[j]) 
 
             { 
 
                 j++; 
 
             } 
 
         } 
 
         if(j == n) 
 
         { 
 
             printf("Yes\n"); 
 
         } 
 
         else 
 
         { 
 
             printf("No\n"); 
 
         } 
 
     } 
 
     return 0; 
 
 }