题目:
https://acm.zzuli.edu.cn/zzuliacm/problem.php?id=1923
题意:
Description
假设表达式定义为:
1. 一个十进制的正整数 X 是一个表达式。
2. 如果 X 和 Y 是 表达式,则 X+Y, X*Y 也是表达式; *优先级高于+.
3. 如果 X 和 Y 是 表达式,则 函数 Smax(X,Y)也是表达式,其值为:先分别求出 X ,Y
值的各位数字之和,再从中选最大数。
4.如果 X 是 表达式,则 (X)也是表达式。
例如:
表达式 12*(2+3)+Smax(333,220+280) 的值为 69。
请你编程,对给定的表达式,输出其值。
Input
第一行: T 表示要计算的表达式个数 (1≤T≤101≤T≤10)
接下来有 T 行, 每行是一个字符串,表示待求的表达式,长度<=1000
Output
对于每个表达式,输出一行,表示对应表达式的值。
Sample Input
3
12+2*3
12*(2+3)
12*(2+3)+Smax(333,220+280)
Sample Output
18
60
69
思路:
首先把给出的字符串转换为中缀表达式,也就是把Smax(X,Y)转换成(X) op (Y)这种形式,根据题意,此处op的优先级应该高于’+’和’*’,这步很容易实现,扫一遍字符串就可以了。转换成中缀表达式之后,直接用逆波兰表达式求值即可。
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef pair<int, int> P;
const int N = 1010;
int precedence(char ch)
{
if(ch == '+' || ch == '-') return 1;
else if(ch == '*' || ch == '/') return 2;
else if(ch == ',') return 3;//定义','的优先级高于'+'和'*'
else return 0;
}
void reverse_polish(char s[], char sta[])
{
char ts[N];
int k = 0, top = 0;
ts[top++] = '@';
for(int i = 0; s[i]; i++)
{
if(s[i] == '(') ts[top++] = s[i];
else if(s[i] == ')')
{
while(ts[top-1] != '(') sta[k++] = ts[--top];
--top;
}
else if(s[i] == '+' || s[i] == '*' || s[i] == ',')
{
while(precedence(ts[top-1]) >= precedence(s[i])) sta[k++] = ts[--top];
ts[top++] = s[i];
}
else if(s[i] >= '0' && s[i] <= '9')
{
while((s[i] >= '0' && s[i] <= '9') || s[i] == '.') sta[k++] = s[i++];
i--;
sta[k++] = ' ';
}
}
while(ts[top-1] != '@') sta[k++] = ts[--top];
sta[k++] = '\0';
}
int work(int m)
{
int res = 0;
while(m) res += m%10, m /= 10;
return res;
}
int Operator(int num1, int num2, char ch)
{
int res;
if(ch == '+') res = num1 + num2;
else if(ch == '*') res = num1 * num2;
else if(ch == ',') res = max(work(num1), work(num2));
return res;
}
void solve(char s[])
{
int ts[N];
int top = 0;
for(int i = 0; s[i]; i++)
{
if(s[i] >= '0' && s[i] <= '9')
{
int num = 0;
while(s[i] >= '0' && s[i] <= '9') num = num * 10 + s[i] - '0', i++;
i--;
ts[top++] = num;
}
else if(s[i] != ' ')
{
int num1 = ts[--top], num2 = ts[--top];
ts[top++] = Operator(num2, num1, s[i]);
}
}
printf("%d\n", ts[0]);
}
int main()
{
char str[N], s[N], sta[N];
int t;
scanf("%d", &t);
while(t--)
{
scanf("%s", str);
memset(s, 0, sizeof s);
int k = 0;
for(int i = 0; str[i]; i++)//把Smax(X,Y)转换成(X) op (Y)的形式
{
if(str[i] == 'S' || str[i] == 'm' || str[i] == 'a' || str[i] == 'x') continue;
if(str[i] == ',') s[k++] = ')', s[k++] = ',', s[k++] = '(';
else s[k++] = str[i];
}
reverse_polish(s, sta);
solve(sta);
}
return 0;
}