帧中继上集成isis之BNMA上集成ISIS_NBMA

拓扑图如上:

R1配置:

R1#SH RUN
Building configuration...

Current configuration : 1099 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 ip router isis
!        
interface Serial0/0
 ip address 200.1.1.1 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 200.1.1.3 103 broadcast //配置CLNS映射
 frame-relay map ip 200.1.1.4 104 broadcast
 frame-relay map clns 103 broadcast
 frame-relay map clns 104 broadcast
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router isis
 net 49.0001.1111.1111.1111.00
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
 

R3的配置

R3#show run
Building configuration...

Current configuration : 1036 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 ip router isis
!        
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 ip address 200.1.1.3 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 isis priority 0
 frame-relay map ip 200.1.1.1 301 broadcast
 frame-relay map clns 301 broadcast
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router isis
 net 49.0001.2222.2222.2222.00
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R4的配置:

R4#show run  
Building configuration...

Current configuration : 1036 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 ip router isis
!        
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 ip address 200.1.1.4 255.255.255.0
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 isis priority 0
 frame-relay map ip 200.1.1.1 401 broadcast
 frame-relay map clns 401 broadcast
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router isis
 net 49.0001.3333.3333.3333.00
!
no ip http server
no ip http secure-server
!

control-plane
!
!line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

验证:查看路由表
R1#sh ip  route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
i L1    3.3.3.0 [115/20] via 200.1.1.3, Serial0/0
     4.0.0.0/24 is subnetted, 1 subnets
i L1    4.4.4.0 [115/20] via 200.1.1.4, Serial0/0
C    200.1.1.0/24 is directly connected, Serial0/0

R3#       show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
i L1    1.1.1.0 [115/20] via 200.1.1.1, Serial0/1
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     4.0.0.0/24 is subnetted, 1 subnets
i L2    4.4.4.0 [115/30] via 200.1.1.1, Serial0/1
C    200.1.1.0/24 is directly connected, Serial0/1

R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
i L1    1.1.1.0 [115/20] via 200.1.1.1, Serial0/2
     3.0.0.0/24 is subnetted, 1 subnets
i L2    3.3.3.0 [115/30] via 200.1.1.1, Serial0/2
     4.0.0.0/24 is subnetted, 1 subnets
C       4.4.4.0 is directly connected, Loopback0
C    200.1.1.0/24 is directly connected, Serial0/2

全网的路由都有了,实验完成!

总结:在接口和多点接口下, IP 映射和CNLS  映射应该分别分配,命令分别是” franme-relay map clns”  和” franme-relay map
ip”