原题链接

The more, The Better


               Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                      Total Submission(s): 7246    Accepted Submission(s): 4257



Problem Description


ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物。但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗?


 




Input


每个测试实例首先包括2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里,每行包括2个整数,a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,如果 a = 0 则代表可以直接攻克第 i 个城堡。b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。


 




Output


对于每个测试实例,输出一个整数,代表ACboy攻克M个城堡所获得的最多宝物的数量。


 




Sample Input


3 2 0 1 0 2 0 3 7 4 2 2 0 1 0 4 2 1 7 1 7 6 2 2 0 0


 




Sample Output


5 13


 

看完背包九讲的依赖背包和泛化背包就会了


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#define maxn 205
using namespace std;
typedef long long ll;

int dp[maxn][maxn], n, m;
vector<int> v[maxn];
void dfs(int i){
	
	for(int j = 0; j < v[i].size(); j++){
		int p = v[i][j];
		dfs(p);
		for(int h = m+1; h > 1; h--)
		  for(int k = h-1; k >= 0; k--){
		  	if(dp[i][h-k] != -1 && dp[p][k] != -1)
		  	dp[i][h] = max(dp[i][h], dp[i][h-k] + dp[p][k]);
		  }
	}
}
int main(){
	
//	freopen("in.txt", "r", stdin);
	while(scanf("%d%d", &n, &m) == 2){
		
		if(n == 0 && m == 0)
		  break;
		int a, b;
		memset(dp, -1, sizeof(dp));
		for(int i = 0; i <= n; i++)
		 v[i].clear();
		dp[0][0] = dp[0][1] = 0;
		for(int i = 1; i <= n; i++){
			scanf("%d%d", &a, &b);
			v[a].push_back(i);
			dp[i][0] = 0;
			dp[i][1] = b;
		}
		dfs(0);
		printf("%d\n", dp[0][m+1]);
	}
	return 0;
}