顺序表应用1:多余元素删除之移位算法

Time Limit: 1000 ms Memory Limit: 650 KiB

Submit Statistic

Problem Description

一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
       1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
       2、本题的目标是熟悉顺序表的移位算法,因此题目必须要用元素的移位实现删除;

Input

 第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。

Output

 输出有n行,为每个顺序表删除多余元素后的结果

Sample Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3

Sample Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5

Hint

 

Source

#include <stdio.h>
#include <stdlib.h>
typedef struct node
{
    int data[100010];
    int last;
} ST;
void creat(ST *head)
{
    int i;
    for(i = 0; i < head->last; i++)
    {
        scanf("%d", &head->data[i]);
    }
}
void delet(ST *head, ST *tail)
{
    int i, num, j;
    num = 0;
    for(i = 0; i < head->last; i++)
    {
        int flag = 0;
        for(j = 0; j < num; j++)
        {
            if(head->data[i] == tail->data[j])
            {
                flag = 1;
                break;
            }
        }
        if(flag == 0)
        {
            tail->data[num] = head->data[i];
            num++;
        }
    }
    tail->last = num;
    for(i = 0; i < num; i++)
    {
        if(i == num - 1)
        {
            printf("%d\n", tail->data[i]);
        }
        else
        {
            printf("%d ", tail->data[i]);
        }
    }
}
int main()
{
    int t;
    ST *head, *tail;
    scanf("%d", &t);
    while(t--)
    {
        head = (ST *)malloc(sizeof(ST));
        tail = (ST *)malloc(sizeof(ST));
        scanf("%d", &head->last);
        creat(head);
        delet(head,tail);
    }
    return 0;
}