Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解题思路:

最长公共字串问题,利用动态规划解决

这里的难点是怎样保存字串的头和尾

动态规划中,分为选和不选两个决策,在本题状态方程中

F[i] = max(F[i],F[i]+dp[i-1]);

如果前者较大,即表示我们不选,此时字串便不连续了,我们保存该位置,如果后者较大,即字串连续,我们将这个位置设为前者的位置

最后最大字串末尾的位置保存着第一个开始连续的位置

#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 10010;
int Mdp[MAXN],MF[MAXN];
int N;
int Msum[MAXN] = { 0 };

int main() {
	cin >> N;
	bool flag = true;
	for (int i = 0; i < N; ++i) {
		cin >> MF[i];
		if (MF[i] >= 0) flag = false;
	}
	if (flag) {
		cout << 0 <<" "<<MF[0]<<" "<<MF[N-1]<<endl;
		return 0;
	}
	//动态规划
	Mdp[0] = MF[0];
	for (int i = 1; i < N; ++i) {
		if (MF[i] > Mdp[i - 1] + MF[i]) {
			Mdp[i] = MF[i];
			Msum[i] = i;  //从这里开始连续
		}
		else {
			Mdp[i] = Mdp[i - 1] + MF[i];
			Msum[i] = Msum[i - 1];  //保存连续的位置
		}
	}
	
	int k = 0;
	for (int i = 1; i < N; ++i) {
		if (Mdp[i] > Mdp[k]) {
			 k = i;
		}
	}
	cout << Mdp[k] <<" "<<MF[Msum[k]]<<" "<<MF[k]<<endl;

	return 0;
}