A/B


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3341    Accepted Submission(s): 2535



Problem Description


要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。




Input


数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。




Output


对应每组数据输出(A/B)%9973。




Sample Input


2 1000 53 87 123456789




Sample Output


7922 6060


因为gcd(B,9973)=1,所以可得B*x+9973*y=1;


A/B=x; 则A=B*x;


因为A/9973=n;


则A=9973*y+n=B*x;


所以B*x-9973*y=n;


#include<stdio.h>
#include<string.h>
#define ll long long
ll gcd(ll a,ll b,ll &x,ll &y)
{
	if(!b)
	{
		x=1;
		y=0;
		return a;
	}
	ll ans=gcd(b,a%b,x,y);
	ll tmp=x;
	x=y;
	y=tmp-a/b*y;
	return ans;
}
ll  val(ll a,ll b,ll c)
{
	ll x,y;
	ll d=gcd(a,b,x,y);
	if(c%d!=0)
		return -1;
	x*=c/d;
	b/=d;
	if(b<0)
		b=-b;
	ll ans=x%b;
	if(ans<=0)
		ans+=b;
	return ans;
}
int main()
{
	int t;
	ll b,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&n,&b);
		ll ans=val(b,9973,n);
		//if(ans==-1)  //题中没让判断没有的情况 
		//	printf("Impossible\n");
		//else
			printf("%lld\n",ans);
	}
	return 0;
}


//数学化简,枚举


#include<stdio.h>
#include<string.h>
int main()
{
	int t;
	long long n,b;
	int i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&n,&b);
		for(i=0;i<9973;i++)
		{
			if((b*i-n)%9973==0)
				break;
		}
		printf("%d\n",i);
	}
	return 0;
}