geometry Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 59    Accepted Submission(s): 45


Problem Description
There is a point P at coordinate (x,y) .
A line goes through the point, and intersects with the postive part of X,Y axes at point A,B .
Please calculate the minimum possible value of |PA||PB| .

Input
the first line contains a positive integer T,means the numbers of the test cases.

the next T lines there are two positive integers X,Y,means the coordinates of P.

T=500 , 0<X,Y10000 .

Output
T lines,each line contains a number,means the answer to each test case.




Sample Input
1 2 1

Sample Output
4 in the sample $P(2,1)$,we make the line $y=-x+3$,which intersects the positive axis of $X,Y$ at (3,0),(0,3).$|PA|=\sqrt{2},|PB|=2\sqrt{2},|PA|*|PB|=4$,the answer is checked to be the best answer.

Source
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
	int t,x,y,b;
	double s,xx,yy;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&x,&y);
		b=x+y;
		xx=sqrt((x*x)+(b-y)*(b-y));
		yy=sqrt((y*y)+(b-x)*(b-x));
		s=xx*yy;
		printf("%.0lf\n",s);
	}
}