Description
The die is cast
InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.
Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.
For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.
We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.
A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence
in S such that a = a1 and b = ak , and aiand ai+1 are connected for
.
We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.
Input
The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy
.
The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.
Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.
The input is terminated by a picture starting with w = h = 0, which should not be processed.
Output
For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.
Print a blank line after each test case.
Sample Input
30 15............................................................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0
Sample Output
Throw 11 2 2 4
这个题只是用了两个DFS,不过我要说的是,我竟然WA了10次!!!竟然是因为换行符号的n写成大写N了啊!!sad。。。 特写进博客以来纪念。。。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include<algorithm>
using namespace std;
int n, m, vis[100][100], nn, a[10003];
char map[100][100];
int jx[]={0,0,1,-1};
int jy[]={1,-1,0,0};
void dfs2(int x, int y)
{
int i, a, b;
for(i=0;i<4;i++)
{
a=x+jx[i];
b=y+jy[i];
if(a>=0&&a<n&&b>=0&&b<m&&vis[a][b]!=2&&map[x][y]=='X')
{
vis[a][b]=2;
dfs2(a,b);
}
}
}
void dfs1(int x, int y)
{
int i, a, b;
for(i=0;i<4;i++)
{
a=x+jx[i];
b=y+jy[i];
if(a>=0&&a<n&&b>=0&&b<m&&!vis[a][b]&&(map[x][y]=='*'||map[x][y]=='X'))
{
vis[a][b]=1;
dfs1(a,b);
if(vis[a][b]!=2&&map[a][b]=='X')
{
vis[a][b]=2;
nn++;
dfs2(a,b);
}
}
}
}
int main()
{
int i, j, num=0, k;
while(scanf("%d%d",&m,&n)!=EOF&&m&&n)
{
num++;
memset(vis,0,sizeof(vis));
for(i=0;i<n;i++)
{
scanf("%s",map[i]);
}
printf("Throw %d\n",num);
k=0;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(!vis[i][j]&&(map[i][j]=='*'||map[i][j]=='X'))
{
nn=0;
dfs1(i,j);
a[k++]=nn;
}
}
}
sort(a,a+k);
for(i=0;i<k;i++)
{
if(i!=k-1)
printf("%d ",a[i]);
else
printf("%d",a[i]);
}
printf("\n\n");
}
return 0;
}