Description:

Finding the exponent of any number can be very troublesome as it grows exponentially. But in this problem you will have to do a very simple task. Given two non-negative numbers UVA10515 Powers Et Al(欧拉降幂)_#include and UVA10515 Powers Et Al(欧拉降幂)_#include_02, you will have to find the last digit of m^n in decimal number system.

Input

The input file contains less than 100000 lines. Each line contains two integers UVA10515 Powers Et Al(欧拉降幂)_#include and UVA10515 Powers Et Al(欧拉降幂)_#include_02 (Less than UVA10515 Powers Et Al(欧拉降幂)_git_05. Input is terminated by a line containing two zeroes. This line should not be processed.

Output

For each set of input you must produce one line of output which contains a single digit. This digit is the last digit of UVA10515 Powers Et Al(欧拉降幂)_#include_06.

Sample Input

2 2

2 5

0 0

Sample Output

4

2

题意:

UVA10515 Powers Et Al(欧拉降幂)_#include_06 的最后一位,数很大套欧拉降幂模板,把模数改为 UVA10515 Powers Et Al(欧拉降幂)_git_08

AC代码:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d\n", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
int ret = 0, sgn = 1;
char ch = getchar();
while (ch < '0' || ch > '9')
{
if (ch == '-')
sgn = -1;
ch = getchar();
}
while (ch >= '0' && ch <= '9')
{
ret = ret * 10 + ch - '0';
ch = getchar();
}
return ret * sgn;
}
inline void Out(int a) //Êä³öÍâ¹Ò
{
if (a > 9)
Out(a / 10);
putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(ll a, ll b, ll mod)
{
if (a >= mod)
a = a % mod + mod;
ll ans = 1;
while (b)
{
if (b & 1)
{
ans = ans * a;
if (ans >= mod)
ans = ans % mod + mod;
}
a *= a;
if (a >= mod)
a = a % mod + mod;
b >>= 1;
}
return ans;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
if (b == 0)
{
x = 1;
y = 0;
return a;
}
int g = exgcd(b, a % b, x, y);
int t = x;
x = y;
y = t - a / b * y;
return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
int d, x, y;
d = exgcd(a, p, x, y);
if (d == 1)
return (x % p + p) % p;
else
return -1;
}

///中国剩余定理模板0
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
int M = 1, y, x = 0;
for (int i = 0; i < n; ++i) //算出它们累乘的结果
M *= a[i];
for (int i = 0; i < n; ++i)
{
int w = M / a[i];
int tx = 0;
int t = exgcd(w, a[i], tx, y); //计算逆元
x = (x + w * (b[i] / t) * x) % M;
}
return (x + M) % M;
}

const int maxn = 1e6 + 10;
char b[maxn], s[maxn];
ll c;
ll mult(ll a, ll b) ///a^b%c
{
ll z = 1;
while (b)
{
if (b & 1)
z = (z * a) % c;
a = (a * a) % c;
b /= 2;
}
return z;
}
ll phi(ll n) ///欧拉函数
{
ll rea = n;
for (int i = 2; i * i <= n; i++)
if (n % i == 0)
{
rea = rea - rea / i;
do
n /= i;
while (n % i == 0);
}
if (n > 1)
rea = rea - rea / n;
return rea;
}
int main()
{
ll bb, n, len1, len2;
while (~scanf("%s%s", b, s))
{
c = 10;
bb = 0;
n = 0;
len1 = strlen(b);
len2 = strlen(s);
if (len1 == 1 && len2 == 1 && b[0] == '0' && s[0] == '0')
{
break;
}
int cnt = phi(10);
rep(i, 0, len1 - 1)
{
bb = (bb * 10 + b[i] - '0') % c;
}
bool ok = 0;
rep(i, 0, len2 - 1)
{
n = n * 10 + s[i] - '0';
if (n > cnt)
{
ok = 1;
n = n % cnt;
}
}
if (ok)
n += cnt;
ll ans = 0;
if (bb == 0)
bb = c;
ans = mult(bb, n);
pld(ans);
}
return 0;
}