描述


You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

题意:给定单词集合S,包含若干单词,找出S中所有满足这样条件的元素p:p==str1+str2 && str1属于S && str2属于S
解法:暴力搜;或者用set,map的查找函数,我在这里用的是map容器,如果有对map容器不了解的,可以看看本博客有关容器的介绍


输入





Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.



输出





Your output should contain all the compound words, one per line, in alphabetical order.



样例输入


a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra



样例输出


alien
newborn



代码:

#include<iostream>
#include<map>
#include<cstring>
#include<cstdio>
using namespace std;
char a[120010][30];
char q[100],p[100];
map<string,int>anc;//创建容器
int main()
{
int n=0,l,j;
while(gets(a[n])!=NULL)
{
anc[a[n]]=1;
n++;
}
j=0;
for(int i=0;i<n;i++)
{
l=strlen(a[i]);
for(int j=0;j<l-1;j++)
{
for(int k=0;k<j;k++)
q[k]=a[i][k];
q[j]='\0';
for(int k=j;k<l;k++)
p[k-j]=a[i][k];
p[l-j]='\0';
if(anc[q]==1&&anc[p]==1)
{
cout<<a[i]<<endl;
break;
}

}
}
return 0;
}