Description



Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?


Input



数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。



第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)



接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)



 


Output



 



只有一行,包含一个整数,为最少花费。


Sample Input



5 6 10 40 1 51 2 52 3 53 4 52 3 30 2 100


Sample Output



8


Hint



对于30%的数据,2<=n<=50,1<=m<=300,k=0;



对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;



对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.




Source

JLOI2011

分层最短路,拆点或者直接做都行。

#include<cmath>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)
const int N = 1e5+ 10;
const int INF = 0x7FFFFFFF;
int n, m, k, s, t, x, y, z;
int ft[N], nt[N], u[N], v[N], sz;
int dp[N][11];

struct point
{
int x, y, z;
point(int x = 0, int y = 0, int z = 0) :x(x), y(y), z(z) {}
bool operator<(const point &a)const { return z > a.z; }
};

int dijkstra()
{
memset(dp, -1, sizeof(dp));
priority_queue<point> p;
p.push(point(s, 0, dp[s][0] = 0));
int ans = INF;
while (!p.empty())
{
point q = p.top(); p.pop();
if (q.x == t) ans = min(ans, q.z);
loop(i, ft[q.x], nt)
{
if (dp[u[i]][q.y] == -1 || dp[u[i]][q.y] > q.z + v[i])
{
p.push(point(u[i], q.y, dp[u[i]][q.y] = q.z + v[i]));
}
if (q.y < k&&dp[u[i]][q.y + 1] == -1 || dp[u[i]][q.y + 1] > q.z)
{
p.push(point(u[i], q.y + 1, dp[u[i]][q.y + 1] = q.z));
}
}
}
return ans;
}

int main()
{
while (inthr(n, m, k) != EOF)
{
intwo(s, t); sz = 0;
rep(i, 0, n) ft[i] = -1;
rep(i, 1, m)
{
inthr(x, y, z);
u[sz] = y; v[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
u[sz] = x; v[sz] = z; nt[sz] = ft[y]; ft[y] = sz++;
}
printf("%d\n", dijkstra());
}
return 0;
}