Problem Description


N times and return the original point firstly.Your task is calcuate the number of schemes.




 



Input


T(T≤10) which denotes the number of test cases. 

For each test case, there is an positive integer  N(N≤106).


 



Output


For each case, output the answer.


 



Sample Input


1 4


 



Sample Output


4


 



妥妥的欧拉函数

#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1000005;
int T, n, m, p[maxn];

void phi()
{
int N = maxn;
for (int i = 1; i<N; i++) p[i] = i;
for (int i = 2; i<N; i += 2) p[i] >>= 1;
for (int i = 3; i<N; i += 2)
{
if (p[i] == i)
{
for (int j = i; j<N; j += i)
p[j] = p[j] - p[j] / i;
}
}
}

int main()
{
phi();
scanf("%d", &T);
while (T--)
{
scanf("%d", &n);
printf("%d\n", p[n + 1]);
}
return 0;
}